Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The two packages conflict, as can be seen in this MWE:

\documentclass{article}
\usepackage{steinmetz}
\usepackage{cancel}

\begin{document}

$\cancelto{0}{a+b}$

\end{document}

When the steinmetz package is loaded, the cancel arrow is misplaced: enter image description here How can this conflict be prevented?

share|improve this question
1  
@Gonzalo: Your example works for me. Try to delete all auxiliary files and run your example once more. If it still doesn't work for you, add \listfiles at the very beginning (even before \documentclass) and inspect the logfile for outdated package versions. –  lockstep Mar 5 '11 at 16:35
    
@lockstep: Well, my code doesn't produce compilation errors; but the arrow used to cancel to zero appears in the wrong position after the steinmetz package is loaded. –  Gonzalo Medina Mar 5 '11 at 16:38
    
@Gonzalo I added an image to show the problem (when you have a bit more reputation you will be able to add images yourself.) –  Alan Munn Mar 5 '11 at 16:40
    
I get this error with Ubuntu 10.10 texlive. Relevant lines of \listfiles are: ` cancel.sty 2000/03/12 v2.1 Cancel math terms steinmetz.sty 2009/06/14 v1.0 Steinmetz symbol for electrotechnics` –  Seamus Mar 5 '11 at 16:41
1  
@Gonzalo: You are right but the problem comes from pict2e (you can test with pict2e instead of steinmetz. steinmetz loads pict2e now I don't know why there is a problem with pict2e. I think like me you have 0 above + and not at the end of the arrow. –  Alain Matthes Mar 5 '11 at 16:51

1 Answer 1

up vote 9 down vote accepted
\documentclass{article}
\usepackage{cancel}

\usepackage[original]{pict2e}

\usepackage{steinmetz}
\begin{document}

$\cancelto{0}{a+b }$

\end{document}

There is a conflict between pict2e and cancel package. By adding \usepackage[original]{pict2e} as above, for my case, the problem is solved.

share|improve this answer
    
That solves the problem for me too. Thanks. –  Gonzalo Medina Mar 5 '11 at 17:07
3  
Without explicitly loading pict2e, adding the original option to \documentclass{article} solves the conflict as well. –  Stefan Kottwitz Mar 5 '11 at 17:12
    
@Stefan: yes; that also solves the problem. –  Gonzalo Medina Mar 5 '11 at 17:18
2  
or use \PassOptionsToPackage{original}{pict2e} before loading steinmetz. –  Martin Scharrer Mar 5 '11 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.