Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Since the last update of MiKTeX, I am experiencing an issue when compiling my work : it stops and the log file says :

! LaTeX Error: File `imakeidx.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name: 
! Emergency stop.
<read *> 

l.104 ^^M

*** (cannot \read from terminal in nonstop modes)

This does not seem to be directly related to my preamble, since I have tried with minimal test documents and the same issue happens; moreover, my document used to compile properly until yesterday, without any change being made since to the preamble. I have removed and reinstalled MiKTeX 2.9 twice, with both basic and complete versions, and none of them worked, as the system does not find imakeidx.sty. Any idea of what is happening, and how to solve it ? Many thanks for any help provided.

share|improve this question
    
The error message means that you do not have the imakeidx package installed in your MiKTeX distribution. –  ChrisS Aug 8 '13 at 4:39
    
I Know that this is what the message is supposed to mean. But this is not the case : I have checked, and installed a complete version of MikTex, refreshed the FNDB, checked with the package manager that imakeidx is properly installed, and it is, and....it does not work ! –  DeGoulde Aug 8 '13 at 4:46
4  
I confirm it. It happened to me also. Somehow miktex update is buggy. I downloaded imakeidx.sty from CTAN and copied it to C:\Program Files\MiKTeX 2.9\tex\latex\imakeidx\ . But last update of miktex said going to remove 12 packages and I didn't care. It means with some other packages too this problem may come. I am not sure which other packages it removed, though. –  Harish Kumar Aug 8 '13 at 4:51
    
Yes ! It works that way, thank you Harish : I must add that once downloaded from CTAN, one has to run pdflatex on imakeidx.dtx (in ...MiKTex 2.9\tex\latex\imakeidx) for imakeidx.sty to be produced. Compiling works fine now. –  DeGoulde Aug 8 '13 at 5:07
1  
I've already opened a bug ticket for that: sourceforge.net/p/miktex/bugs/2282 –  karlkoeller Aug 8 '13 at 6:26
show 1 more comment

1 Answer

up vote 3 down vote accepted

This awnser simply turns comments into an awnser. Creit goes to the comment authors

It is a miktex bug that can worked around as @HarishKumar describes:

Build the package from [ctan] (run pdflatex on imakeidx.dtx), and place makeidx.sty in the corresponding folder of your tex tree (MiKTex 2.9\tex\latex\imakeidx).

@karlkoeller reported this as a bug which has been resolved. It is not availalbe in the miktex updates right now, but should be rather soon.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.