Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried to do the following:

% arara: lualatex: {options: -output-directory=.\output\ -aux-directory=.\auxiliary}

I did not succeed. I also tried starting the command with -- as well as absolute path with / or \. A nice to have extra would be, that the folders become created if not already existing.

A second question: Will LuaLaTeX know where the auxiliaries are stored in a second run?


I am working on Win XP 64 with MikTeX 2.9

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The answer is: it is not possible... but it is not arara's fault.

Infact, the command line --aux-directory is implemented ONLY for a few tools in MiKTeX distribution (it doesn't even exists in TeX Live).

If, from the command line, you run lualatex --help you will get

  The following regular options are understood:

   --8bit                        ignored, input is assumed to be in UTF-8 encoding
   --credits                     display credits and exit
   --debug-format                enable format debugging
   --default-translate-file=     ignored, input is assumed to be in UTF-8 encoding
   --disable-write18             disable \write18{SHELL COMMAND}
   --draftmode                   switch on draft mode (generates no output PDF)
   --enable-write18              enable \write18{SHELL COMMAND}
   --etex                        ignored, the etex extensions are always active
   --[no-]file-line-error        disable/enable file:line:error style messages
   --[no-]file-line-error-style  aliases of --[no-]file-line-error
   --fmt=FORMAT                  load the format file FORMAT
   --halt-on-error               stop processing at the first error
   --help                        display help and exit
   --initialize                  be iniluatex, for dumping formats
   --interaction=STRING          set interaction mode (STRING=batchmode/nonstopmode/scrollmode/errorstopmode)
   --jobname=STRING              set the job name to STRING
   --kpathsea-debug=NUMBER       set path searching debugging flags according to the bits of NUMBER
   --lua=s                       load and execute a lua initialization script
   --[no-]mktex=FMT              disable/enable mktexFMT generation (FMT=tex/tfm)
   --nosocket                    disable the lua socket library
   --output-comment=STRING       use STRING for DVI file comment instead of date (no effect for PDF)
   --output-directory=DIR        use existing DIR as the directory to write files in
   --output-format=FORMAT        use FORMAT for job output; FORMAT is 'dvi' or 'pdf'
   --[no-]parse-first-line       disable/enable parsing of the first line of the input file
   --progname=STRING             set the program name to STRING
   --recorder                    enable filename recorder
   --safer                       disable easily exploitable lua commands
   --[no-]shell-escape           disable/enable \write18{SHELL COMMAND}
   --shell-restricted            restrict \write18 to a list of commands given in texmf.cnf
   --synctex=NUMBER              enable synctex
   --translate-file=             ignored, input is assumed to be in UTF-8 encoding
   --version                     display version and exit

Alternate behaviour models can be obtained by special switches

  --luaonly                run a lua file, then exit
  --luaconly               byte-compile a lua file, then exit

As you can see, --aux-directory is not present.


You can obtain something similar depending on your editor, for example WinEdt and TeXMaker have a similar option. See this thread: Is there a way to configure pdflatex to make all but the .tex and .pdf files hidden files?.

share|improve this answer
    
Thanks. But --output-directory=DIR exists. Shouldn't that work somehowe? From my arara.log: 08 Aug 2013 16:28:34.563 TRACE CommandTrigger - Command: lualatex --output-directory=.\output\ "Minimalbeispiel.tex" –  LaRiFaRi Aug 8 '13 at 14:27
1  
@LaRiFaRi Unfortunately not in MiKTeX. It is a long time bug. It works in TeX Live. –  karlkoeller Aug 8 '13 at 14:39
    
@LaRiFaRi BTW, what editor are you using? –  karlkoeller Aug 8 '13 at 14:40
    
TeXnicCenter 2.0 Beta2 –  LaRiFaRi Aug 8 '13 at 14:41
    
@LaRiFaRi Unfortunately I don't know a method to obtain something similar in TeXnicCenter. If you want to try WinEdt there is a possibility with it. There is also an arara add-on made by me to have full arara integration. –  karlkoeller Aug 8 '13 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.