Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I run TeX Live 2013 on Win 7(x64) and was doing fine with updates and everything until today. I went for another update, when suddenly the following error message popped up when the updater tried to run updmap-sys:

The program can't start because runscript.dll is missing from your computer. Try reinstalling the program to fix this problem.

The same happened with fmtutil-sys.

So I did a reinstall of the whole distribution and the same error occurred during the install. Same error message and all after the installation tried to run updmap-sys.

So I am asking myself, what I can do and what is going on.

Can someone help me out?

share|improve this question
1  
Did you cmd as Run as adminstrator and type at commandline window C:\Windows\system32\ tlmgr update -all -self there was a infrastructure update recently so the above command takes care of it for all updates. –  texenthusiast Aug 9 '13 at 20:06
1  
run this tlmgr update -all -self 2 -3 times until it changes to a new nearest repository –  texenthusiast Aug 9 '13 at 20:10
1  
I think there is bug in the recent tlmgr.pl update as I can experience it on Win7 64 bit os TeXLive 2013 at updmap-sys failed <status 53> .... Also Related Old Thread at latex-community.org –  texenthusiast Aug 9 '13 at 20:26
1  
Before we jump to conclusions, let's see if someone else notice same issues. My Infrastructure update was successful and at last updmap-sys fired an error as show in log file. for debugging purpose some snippet of log file –  texenthusiast Aug 9 '13 at 20:52
1  
"The program can't start because runscript.dll is missing from your computer" was the popup window I got when updmap-sys fired an error. I think we are in same boat I suppose. –  texenthusiast Aug 9 '13 at 21:00
show 11 more comments

2 Answers 2

up vote 5 down vote accepted

This was an error from our side. Please simply update again, it will fix the problem with todays update of texlive.infra and texlive-scripts.

share|improve this answer
add comment

Well, all of this got resolved with the present update of tlmgr. So the problem took care of itself or more appropriately someone took care of it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.