Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Here's another newbie question about org-mode's LaTeX export:

Given this file test.org

#+BEGIN_abstract
asdf, or whatever I want to write in the abstract ...
#+END_abstract

* Introduction
  This is my inroduction ...

an export via

$ emacs --batch --visit=./test.org --funcall org-export-as-latex

Produces this error:

unbalanced begin/end_abstract blocks with "#+BEGIN_abstract
"

When I switch the abstract and introduction in the file, everything works fine:

* Introduction

#+BEGIN_abstract
asdf, or whatever I want to write in the abstract ...
#+END_abstract

But then, the abstract comes within the introduction. However, I need it to be before the introduction.

How can I achieve this?

I'm running Emacs 23 on Ubuntu 12.04.

UPDATE following the advice by @giordano, I created a file emacs_setup.el:

(defun org-export-latex-no-toc (depth)  
    (when depth
      (format "%% Org-mode is exporting headings to %s levels.\n"
              depth)))
(setq org-export-latex-format-toc-function 'org-export-latex-no-toc)

And changed my org file to

#+TITLE: My Document
#+AUTHOR: Andreas H.

#+LATEX: \tableofcontents
#+LATEX: \listoftables
#+LATEX: \listoffigures

#+begin_abstract
  asdf, or whatever I want to write in the abstract ...
#+end_abstract

* Introduction

But when calling

$ emacs --batch -l emacs_setup.el --visit=test.org --funcall org-export-as-latex

I get the exact same error.

share|improve this question
    
See orgmode.org/worg/org-tutorials/org-latex-export.html#sec-11-1 Does it help? Perhaps you need also to set a title before the abstract. –  giordano Aug 10 '13 at 14:31
    
no, it doesn't help. See updated question. –  andreas-h Aug 10 '13 at 14:50
    
I don't know what's the problem, with Emacs 24 and org-mode 8 I don't get that error. –  giordano Aug 10 '13 at 15:02
    
maybe a change in org-mode 8? I'll try installing emacs24 with the new org-mode and see if the error persists. –  andreas-h Aug 10 '13 at 15:57
    
@giordano Thanks for your help, installing Emacs 24 and org-mode 8.0.7 indeed solved my problem. –  andreas-h Aug 11 '13 at 8:53
add comment

migrated from stackoverflow.com Aug 11 '13 at 15:17

This question came from our site for professional and enthusiast programmers.

1 Answer

I usually use the LaTeX code directly for this result

\begin{abstract}

This is the abstract.

\end{abstract}


* Introduction

  This is the introduction.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.