Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm new here. I'm typing my Thesis and I'm using two languages (Spanish, English). This is my code:

\documentclass[hidelinks,letterpaper,titlepage,12pt,oneside,spanish,final]{report_eie}
\usepackage[english,spanish]{babel} 
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amssymb}
.
.
\usepackage{indentfirst} %(Because I have declared a new language, english)
\usepackage[apaciteclassic]{apacite}
\usepackage[round,authoryear]{natbib}
.
.
\begin{document}
\selectlanguage{spanish} 
.
.
.
\bibliographystyle{apacite}
\renewcommand{\bibname}{REFERENCIAS}
\let\oldbibsection\bibsection
\bibliography{biblioteca} 
.
.
.
\end{document}

All works but the bibliography is showed in English (for example, the ordinal numbers are showed "Nth", instead of Nª, "and" instead of "y", etc). If I type \usepackage[spanish]{babel} and delete \selectlanguage{spanish} the bibliography is showed in Spanish. What I can do? I need to use both languages.

share|improve this question
    
Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  karlkoeller Aug 17 '13 at 15:53
3  
Can you add to your question two english and two spanish bib entrys? –  Kurt Aug 17 '13 at 16:02
3  
I would like to point out the combination \documentclass[spanish]{..} with \usepackage[english,spanish]{babel} doesn't make Spanish the main language (the second spanish is just ignored). If you want to set spanish as the main language, you must upgrade to babel 3.9 and use \usepackage[english,main=spanish]{babel} or remove spanish from the global options. –  Javier Bezos Aug 17 '13 at 16:33
    
@JavierBezos at least all names and hyphenation are changed to Spanish, am I wrong? –  karlkoeller Aug 17 '13 at 17:39
    
I just removed spanish from the line \documentclass[hidelinks,letterpaper,titlepage,12pt,oneside,spanish,final]{repo‌​rt_eie} and everything seems to work fine. –  GregM Aug 17 '13 at 19:31

1 Answer 1

If I understand you correctly, you want Spanish entries in the bibliography to be handled like they should be in Spanish, and English entries similarly in English?

If this is the case, You'll have to use a bibtex style that is capable of switching the language for each entry in the bibliography.

biblatex provides such a functionality, by using an additional field 'hyphenation' for each bibtex database entry. This field indicates the language the entry should be presented in, thus allowing biblatex to put each entry in a correct babel language environment. Then you'll get each entry in the bibliography to behave in its correctly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.