Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently did a complete reinstall of Windows 7, installed all updates, and reinstalled all of my programs, including MikTeX using the 2.9 64-bit version. I ran a XeLaTeX document I had created and successfully run before, in order to re-download and autoinstall most of my packages. This went well, except for polyglossia.sty and gloss-english.ldf, both parts of the polyglossia package; MikTeX prompts popped up (I had set the autoinstall on "ask me" at install) twice for the first file and three times for the second, before moving on and generating the document anyway. The same thing would happen with those two every time I ran the document; I tried changing the autoinstall download from "random" to, eventually, a dozen or so repositories with no better luck. I looked in the directory cited in the autoinstall prompt, and still no polyglossia directory.

Thinking perhaps it was a glich in the 64-bit version of MikTeX, I uninstalled it--successfully except that Windows was for some reason unable to remove the empty MikTeX 2.9 directory from Program Files (86)--I removed it myself, but had to assert administrator privilege to do so. I then ran CCleaner on the Windows registry; there were fixes to be made, but none that appeared to have anything to do with MikTeX. I then downloaded the 32-bit version and installed it, but everything just went as before. And I don't even want to think about the manual download-and-install fiasco that I tried next; it seems you can't get polyglossia.sty to extract from polyglossia.dtx without polyglossia.sty installed first.

Then it occurred to me to look in ALL of my C:\Program Files (x86)\MikTeX 2.9\tex subdirectories, not just the xelatex subdirectory where MikTeX was looking for them, and lo and behold, there polyglossia was... in the latex subdirectory. For all I know, MikTeX was fetching it and putting it there every single time I clicked the go-get-it button. So the question becomes: do I either tell MikTeX where to put it (and how), or where it should be looking for it, (and again, how)? Or should I just move the polyglossia directory to C:\Program Files (x86)\MikTeX 2.9\tex\xelatex with a simple cut-and-paste and be done with it?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Polyglossia is in \tex\latex\polyglossia\polyglossia.sty in my miktex. As polyglossia is moving toward luatex this is the correct place and it works for me.

It sometimes happens that miktex gets confused about the location of a package (mostly when package are rearranged or moved to another location). In such case try at first to synchronize the package repository (package manager, menu repositories). If you have a multiuser installation do it in admin and in user mode. Also recreate the FNDB -- again as admin and as user. Make sure that you are using an up-to-date repository. http://www.miktex.org/pkg/repositories.

share|improve this answer
    
Yes, this worked. Thank you very much. A note for those with the same problem reading this: the Package Manager can be found in Start Menu > All Programs > MikTeX 2.9 > Maintenance (and/or Maintenance (Admin), depending on how you're running it); then on the toolbar, Repository > Synchronize. To change FDNB, same Start Menu routine, but open Settings instead, first item on the General tab. –  Stonefeather Grubbs Aug 20 '13 at 2:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.