Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing a thesis, and want to use the APA citation style. I've installed the apacite package. Possibly incorrectly, but TeXworks does not give any errors concerning the package. It does give errors with all \cite{} commands, which seem to mess up with the \begin{} and \end{} commands. If I comment out the \usepackage{apacite} statement, everything works just fine (even if I keep the bibliographystyle apacite!) Anyone who has any idea what could be happening here? Thanks in advance!

Some example errors:

! Missing } inserted.

l. 19 Charles Darwin on language \cite{Darwin71}

?

! Too many }'s.

l.20

?

!Latex error: \begin{document} ended by \end{quote}

And this is the master file I try to typeset:

\documentclass[10pt]{book} 

\usepackage{url}
\usepackage{geometry}
\usepackage{comment}
\usepackage{pdflscape}
\usepackage{natbib}
\usepackage{titling}
\usepackage{amsmath} 
\usepackage{amssymb} 
\usepackage{appendix}
\usepackage{makeidx} %If you want to generate an index, automatically 
\usepackage{graphicx}
\usepackage{tipa}
\usepackage{apacite}

\begin{document} 

\author{Ellen Maassen} 
\title{Language as a Threefold Adaptive System \newline\\ {\Large The Emergence of Phonological Compositionality}}
\date{\today} 

\maketitle

\frontmatter
\tableofcontents 
\include{preface}

\mainmatter 
\input{chaptr12}
\input{chaptr22} 
\input{chaptr32} 
\input{chaptr42} 
\input{chaptr52}  
\input{chaptr62}
\input{chaptr72}

\appendix
\input{Geluidjes}
\input{bootstrapping}

\backmatter  
\bibliographystyle{apacite} 
\bibliography{refs} 
\printindex 

\end{document}
share|improve this question
1  
Load natbib AFTER apacite and you should have no problems. –  karlkoeller Aug 21 '13 at 14:43
    
BTW: Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  karlkoeller Aug 21 '13 at 15:38
    
Any feedback about what karlkoeller proposed to solve your problem? –  Ludovic C. Aug 26 '13 at 14:39
    
That did it, thanks! –  user35482 Aug 30 '13 at 14:25
    
@karlkoeller Please add that as answer. –  Christoph Mar 2 at 0:48

1 Answer 1

This problem can be resolved simply loading the package natbib after apacite.

Note that you can avoid loading natbib if you pass the option natbibapa to apacite.

\usepackage[natbibapa]{apacite}

In this way apacite loads natbib with the options longnamesfirst and sort, needed in order to meet the APA specifications.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.