Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Might seem like an odd thing to do, but so far it's proven beyond my novice-level Latex abilities, and related posts I've looked at on this site seem a little more complicated than what I need. In particular, I'm writing a dissertation, and my university requires the following:

  1. 12pt Times New Roman
  2. Double Spaced throughout
  3. Chapter Headings are distinguished only by centering, and the use of all capital letters (this includes the headings for things like the table of contents), and the use of what in komascript amounts to the chapterprefix=on option

The komascript manual was pretty clear on how to get headings centered. Still, my headings are formatted by default with the following undesired attributes:

  1. Some font other than Times New Roman
  2. Bold-Face
  3. Huge white space above the heading (I need no space but the top margin)

So, how to I tell komascript to back off a little, and not add all the extra formatting to the headings?

Here's my working template so far:

\documentclass[12pt,letterpaper,oneside,chapterprefix=on]{scrbook}

%Margins
\usepackage[letterpaper,left=1.5in,top=1in,right=1in,bottom=1in]{geometry}

%Type
\usepackage{fontspec}
\setmainfont{Times New Roman}
\usepackage{unicode-math}
\setmathfont{xits-math.otf}
\usepackage[doublespacing]{setspace}
\setlength\parindent{0.5in}

%Other
\usepackage{microtype}
\usepackage{lipsum}

\setkomafont{chapter}{\centering}

\begin{document}

\frontmatter

%Flyleaf
\clearpage\thispagestyle{empty}\mbox{}\clearpage\setcounter{page}{1}

\chapter*{Abstract Title Page}
\chapter*{Abstract}
\chapter*{Copright Page}
\chapter*{Title Page}
\tableofcontents
\listoffigures

\mainmatter
\chapter{Introduction}
\lipsum
\appendix

\backmatter

\end{document}
share|improve this question

1 Answer 1

up vote 2 down vote accepted

The komafont settings for chapter, section, etc. contain only the font size argument. You need to change the underlying formatting element disposition as well (also available as sectioning). This setting normally contains \normalcolor\sffamily\bfseries here we change it to \normalcolor\rmfamily:

\setkomafont{disposition}{\normalcolor\rmfamily}

There is also an option for small headings.

\documentclass[headings=small]{scrbook}
share|improve this answer
    
Yep, that was it! In my mind I was thinking of of disposition as merely a shortcut for operating on all headings at once, as opposed to a distinct parent node in a hierarchy. I'm off to the races now. Sorry I can't up-vote your answer...first time on the site. Thanks a bunch though. –  Brad Aug 22 '13 at 18:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.