Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I read about these several questions, how to use a font size other than 10, 11 oder 12 (see e.g. this one) using KomaScript, but somehow, that won't work for me. I use XeLaTeX to compile my document (in order to change the font also, but the problem already occurs without that).

Then using the MWE

\documentclass[fontsize=13,DIV=12]{scrbook}
\usepackage[no-math]{fontspec}
\usepackage{xunicode,xltxtra} 

\begin{document}
    Dieser Text sollte in Schrift 13pt sein, ist aber 12pt
\end{document}

The warning then is

LaTeX Font Warning: Font shape `OT1/cmr/m/n' in size <13> not available

(Font) size <12> substituted on input line 1366.

Which i suspect is due to OT1 but how do I tell XeLaTeX to use T1 (also because it's a german text, as the MWE might already suggest)?

share|improve this question
    
I think this is only related to the optical size of the font, not the actual size. Since Computer Modern only has fonts for the 12pt optical size, not 13pt, it will fall back to the closest optical size available (but the text should still be 13pt). –  You Aug 22 '13 at 9:15
    
So, he uses 12pt (optical) and scales that up to 13pt to get actual 13pt size but with a „12pt-look“ (of the vectorized font)? –  Ronny Aug 22 '13 at 9:18
    
Actually, my comment above is incorrect. See tex.stackexchange.com/questions/58087/…. –  You Aug 22 '13 at 9:20
    
You might be interested in tex.stackexchange.com/a/108732/5049 which explains what KOMA-Script's fontsize option actually does –  cgnieder Aug 22 '13 at 9:25
    
That's nice to know and i am okay with the computed sizes, als long as it would really be 13pt \normalsize and not still 12pt, because the 13pt are available with the font i use (or even XeLaTeX uses normally). –  Ronny Aug 22 '13 at 9:39

2 Answers 2

up vote 8 down vote accepted

You can ignore the message: It is only a side effect of the calculation. The font itself is in 13pt:

Add

 \fontsize{12pt}{12pt}\selectfont Dieser Text sollte in Schrift 13pt sein, ist aber 12pt

after your text to see the difference.

If you want to avoid the warning altogether add \RequirePackage{fix-cm} before \documentclass.

share|improve this answer
    
Thanks for the hint to try - you're right. The warning is kind of misleading here, i think. The fix-cm worked for that MWE, but on first try not for my huge document - but i'll have to take a closer look on that. –  Ronny Aug 22 '13 at 15:11

To get rid of this message you can write an own file scrsize13pt.clo. As Markus Kohm said in his printed book (German version chapter 17.1, page 428; sorry, I have only the book in German) KOMA-Script with the option fontsize=13 or fontsize=13pt searched for a file scrsizexxpt.clo or scrsizexx.clo with xx stands for the given size, here 13. If it finds this file a recalculation by KOMA-Script is not nececcary and you will get no warning.

You can use file scrsize12pt.clo, copy it to scrsize13pt.clo and change the values to 13 pt. Please be careful this it not so easy: You have to define for example for all fontsize macros like \normalsize or \Large the propper values.

share|improve this answer
    
I red about that (though not in the german book itself, though i'm german) - but as far as I saw, that's really not that easy, so for now Ulrikes answer does provide a better solution (though that might also be just for me) to my answer. –  Ronny Aug 22 '13 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.