Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I wrote the following code :

\begin{columns}
    \begin{column}{.48\textwidth}
            \begin{block}{Context} \vspace{+0.05cm}
            \begin{itemize}
                \item Bob \pause
                \item Bob2 \pause
            \end{itemize}
            \end{block}
    \end{column}
    \hfill%
    \begin{column}{.48\textwidth}
            \begin{figure}
            \centering
            \includegraphics[scale=0.18]{myPic.jpg} 
            \caption{myPic title}
            \end{figure}
    \end{column}
\end{columns}

I don't manage to display at first Bob AND in the meantime the entire figure myPic (picture+caption). First of all, using pause make the picture not hidden, and the caption is only read at the 3th step. I also tried to use

 onslide<1>

for the figure but it didn't worked.

Please also note that I am using :

\setbeamercovered{transparent}

To sum up, here are the steps I would like to obtain if possible.

Step 1: Bob and the entire figure (picture+caption) are displayed

Step 2: Step 1 remains on screen + Bob2 is displayed

Thank you in advance for your help.

share|improve this question
    
For the edit, change <1> to <1-> before bob –  percusse Aug 26 '13 at 13:55
1  
Thanks I sorted this out in checking the command \only that I didn't know ;) –  Header12 Aug 26 '13 at 13:58
add comment

1 Answer 1

up vote 5 down vote accepted

You have some problems with your code such as /pause instead of \pause, missing \end{figure} etc. When fixed it looks like the code works properly

\documentclass{beamer}
\usepackage{mwe}
\begin{document}
\begin{frame}{frametitle}
\begin{columns}
    \begin{column}{.48\textwidth}
            \begin{block}{Context} \vspace{+0.05cm}
            \begin{itemize}
                \item<1> Bob
                \item<2> Bob2
            \end{itemize}
            \end{block}
    \end{column}
    \hfill%
    \begin{column}{.48\textwidth}
            \begin{figure}
            \centering
            \includegraphics<1>[scale=0.18]{example-image} 
            \only<1>{\caption{myPic title}}
            \end{figure}
    \end{column}
\end{columns}
\end{frame}
\end{document}
share|improve this answer
    
It's working very fine, I didn't know the fact that you can force the content to be displayed thanks to <number> . I added <1-> or <2-> so that it remains on screen. Thank you for your help! –  Header12 Aug 26 '13 at 13:56
    
You might also provide a figure-free version with the help of \captionof as there's no point in having a floating environment here. –  Claudio Fiandrino Aug 26 '13 at 13:57
    
@Header12 My pleasure. The whole overlay specification is based on that. Check the manual for lots of other options –  percusse Aug 26 '13 at 13:57
    
@ClaudioFiandrino That's what I used to think, but Gonzalo Medina reminded me that beamer changes the meaning of figure and table environments so they are not floats anymore. But still I think captions are redundant in a presentation. –  percusse Aug 26 '13 at 13:58
    
@ClaudioFiandrino & @ percusse : Do you think I shouldn't use "caption" ? Sorry but I am not a pro in presentation making, as you could realise. What should I use instead then ? –  Header12 Aug 26 '13 at 14:00
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.