Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I include a table of contents in a Beamer slide show, each section entry in the TOC ends up linking to the second slide in that section. I would have expected it to link to the first slide. What am I doing wrong?:

\documentclass{beamer}

\begin{document}
\begin{frame}{Test TOC}
  \tableofcontents
\end{frame}

\section{Section 1}

\begin{frame}
  \frametitle{Test 1}
\end{frame}

\begin{frame}
  \frametitle{Test 2}
\end{frame}

\end{document}

Just to clarify: when I click Section 1 in the TOC, it takes me to the slide Test 2.

UPDATE: I am actually not sure if it takes me to slide Test 2. When I click the link, the viewer (Evince and Okular) displays most of Test 2, but with a tiny strip of the slide Test 1 visible at the top of the window. I suspect that the viewer may treat the link as pointing to the very bottom of slide Test 1 and then aligns that with the top of the window. Could this be the explanation?

share|improve this question
    
A problem with your packages; outdated, perhaps? In my system (TeX Live2013) everything works OK with your MWE. –  Gonzalo Medina Aug 28 '13 at 20:02
    
@GonzaloMedina I am using TexLive 2013 too. I need to check my local texmf tree... –  Thomas Arildsen Aug 28 '13 at 20:17
1  
@JosephWright Indeed! I just checked and the problem appears using Evince! Have you (Thomas Arildsen) tried using another viewer? –  Gonzalo Medina Aug 28 '13 at 20:18
    
I am using Evince too. –  Thomas Arildsen Aug 28 '13 at 20:19
    
It happens in Okular as well. –  Thomas Arildsen Aug 30 '13 at 9:19
show 1 more comment

3 Answers

This was due to a bug in beamer, which only shows up with some viewers. The problem comes down to where the target is located for page links. The behaviour was to place this in a footer, which is not really correct. The code has now been updated to place the link in the 'correct' place during shipout, and this fix will appear in the upcoming v3.28 update to CTAN.

share|improve this answer
add comment

As you already explained there is a workaround, until the beamer package is updated with the bug fix Joseph Wright mentions. By putting your PDF viewer in Single Page mode you are able to correct this behavior, which was also present in Adobe Acrobat 11 (and probably <11 as well). The simplest way, that doesn't require the viewer to select this view mode manually, is to add the pdfpagelayout option to your hyperref options, like so:

\documentclass[hyperref={pdfpagelayout=SinglePage}]{beamer}

Note that the hyperref options must be in curly brackets and supplied to the hyperref option of the beamer class. This is due to beamer's dependency on the hyperref package, which it loads for you automatically.

share|improve this answer
1  
Welcome to TeX.SX. –  Claudio Fiandrino Oct 7 '13 at 18:57
add comment
up vote 2 down vote accepted

I have found a solution, or maybe a workaround? The described problem appeared when viewing slides in "continuous" mode. If I disable this so that the viewer jumps from slide to slide instead of scrolling across them, clicking links does take me to the right slide. This goes for both Evince and Okular.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.