Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

EDIT: It looks like this solution \detokenize{} is working in my situation. Mark it for answered.

I've searched all over Internet including Stackoverflow, but I can not found a solution in this problem:

\usepackage[unicode]{hyperref}
\begin{document}
\begin{figure}[H]
\href{run:/$HOME/Workspace/ĄČĘĖĮŠŲŪŽ/tests/V-832-2.qti}{\includegraphics[scale=0.5]{Graph1}}
\end{figure}
\end{document}

Problem with this file is this (when I click onto a link in generated PDF):

Workspace/\begingroup \let \relax \relax \endgroup
[Pleaseinsert\PrerenderUnicode{Ą}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Č}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Ę}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Ė}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Į}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Š}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Ų}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Ū}intopreamble]\begingroup \let \relax
\relax \endgroup
[Pleaseinsert\PrerenderUnicode{Ž}intopreamble]/testams/V-832-2.qti

How to make hyperref work with a Unicode paths?

Suggestions to use utf8, utf8x for inputenc didn't work for me.

My inputenc is with those options: \usepackage[utf8x]{inputenc}.

Using a unicode=true tag didn't solve my problem.

share|improve this question
1  
Using \usepackage[unicode=true]{hyperref} doesn't help in your case? –  Ludovic C. Sep 2 '13 at 9:09
    
Are you loading inputenc? With what option? –  egreg Sep 2 '13 at 9:35
1  
I get no error with utf8x. I would guess that your ucs version is outdated. You could try to do what the message says; Insert \PrerenderUnicode{Ą} and so on in your preamble. With utf8 as inputenc option one has first to add sensible definitions for the chars, e.g. with newunicodechar. –  Ulrike Fischer Sep 2 '13 at 13:13
    
\unhbox \voidb@x \bgroup \let \unhbox \voidb@x \setbox \@tempboxa \hbox {u\global \mathchardef \accent@spacefactor \spacefactor }\accent 9 u\egroup \spacefactor \accent@spacefactor <---- I've got this string in a filename path only for one letter. It means that \PrerenderUnicode{} does not work in this situation. –  user2215964 Sep 3 '13 at 5:57

1 Answer 1

You can try:

\href{\detokenize{...}}{...}

Also I have doubts that $HOME can be used here, because a shell or similar is needed to interpret the environment variable.

share|improve this answer
    
Very useful. One question about this: how to make a href links absolute? Now href links file in relative path: $HOME/dir/file becomes &HOME/workdir/texfile:$HOME/dir/file. –  user2215964 Sep 3 '13 at 12:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.