Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How do I embed fonts in XeLaTeX's PDF output?

I am printing directly onto my printer, which requires PDF, EPS or PS input with embedded fonts.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

I've used XeLaTeX for a document which when I open it in Adobe Reader shows that a subset of the font is already embedded. So I think it should be already happening for your document. Just check it in the File->Properties->Fonts settings.

Fonts subset embedded already.

share|improve this answer
Actually I tried printing it just after reading this and found that it printed just fine! - Thank you XeLaTeX! :D – A T Sep 5 '13 at 10:29
As mentionned in this post (for PDFLaTeX), there might still be a problem if you insert images in pdf without embedded fonts. – Luc M Dec 29 '14 at 17:33

I wonder why they don't make this easier to do.

Here is a solution to embedding fonts after you compiled the PDF file:

  1. open your pdf file,
  2. select file -> print
  3. set your printer to be Adobe printer (assuming you already installed it)
  4. click on properties
  5. click the tab "Adobe PDF Settings"
  6. uncheck "Rely on system fonts only; do not use document fonts"
  7. click on the Edit... after Default Settings
  8. click on Fonts, add those missing fonts to "Always Embed" (It is recommended to save the properties as a new setting.)
  9. print the pdf file with the new settings, and your new pdf file should be good to go.

Tip: when (or if) it asks you to save the PDF settings file, save it in the suggested Adobe settings folder

Source: Click Here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.