Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using this method to write description in a new line in beamer,

enter image description here

But how can I remove the indent at the new line so it aligns with the \item[]?

This is what I have right now.

\pdfminorversion=4
\documentclass{beamer}
\usetheme{Madrid}
\usepackage{appendixnumberbeamer}
\usepackage{textpos}
\usepackage{animate}
\usepackage{siunitx}
\usepackage{caption}
\usepackage{subcaption}

\begin{document}

\begin{frame}{title}
  \fontsize{8pt}{9}\selectfont
  \begin{columns}
    \centering
    \column{.7\textwidth}
    \vbox to .8\textheight{%
    \begin{figure}
      \centering
      \begin{subfigure}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{../Fig1}
      \end{subfigure}%\hfill
      \begin{subfigure}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{../Fig2}
      \end{subfigure}\\\vfill
      \begin{subfigure}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{../Fig3}
      \end{subfigure}%\hfill
      \begin{subfigure}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{../Fig4}
      \end{subfigure}%
    \end{figure}
    }%

    \column{.3\textwidth}
    Imperfection in Tx and Rx may cause IQ imbalance and other system error.\\
    \begin{description}[leftmargin=0pt]
    \item[Gain Imbalance] \hfill \\Amplitude is different for I and Q.
    \item[Quadrature Error] \hfill \\Phase between I and Q is not \ang{90}.
    \item[IQ Offset] \hfill \\I and Q are not centered at zero.
    \item[Gain Compression] \hfill \\Distance $d$ between constellation points is power dependent.
    \end{description}

  \end{columns}
\end{frame}

\end{document}
share|improve this question

2 Answers 2

up vote 4 down vote accepted

One easy way is to set description width to be equal to -\labelsep; in the following example I made the change local to a frame, but if you move the line

\setbeamersize{description width=-\labelsep}

the change will be global:

\documentclass{beamer}

\begin{document}

{
\setbeamersize{description width=-\labelsep}
\begin{frame}
\begin{description}
\item[First]\mbox{}\\ The first item.
\item[Second]\mbox{}\\ The second item.
\item[Third]\mbox{}\\ The third item.
\end{description}
\end{frame}
}

\end{document}

enter image description here

An with the updated code in the question, there's \begin{description}[leftmargin=0pt], so the string "leftmargin=0pt" is taken as the widest label, overriding the previously defined description width; all that needs to be done is to delete [leftmargin=0pt]. Notice also that I replaced figure with center and subfigure with minipage (there's really no need for neither the figure nor for the subfigure environments in beamer):

\documentclass{beamer}
\usepackage{siunitx}

\begin{document}

{
\setbeamersize{description width=-\labelsep}
\begin{frame}{title}
  \fontsize{8pt}{9}\selectfont
  \begin{columns}
    \column{.7\textwidth}
    \vbox to .8\textheight{%
    \begin{center}
      \begin{minipage}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{example-image-a}
      \end{minipage}%\hfill
      \begin{minipage}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{example-image-b}
      \end{minipage}\\\vfill
      \begin{minipage}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{example-image-c}
      \end{minipage}%\hfill
      \begin{minipage}[b]{.5\textwidth}
        \centering
        \includegraphics[width=\textwidth]{example-image-a}
      \end{minipage}%
      \end{center}
    }%

    \column{.3\textwidth}

    Imperfection in Tx and Rx may cause IQ imbalance and other system error.\\
    \begin{description}
    \item[Gain Imbalance] \hfill \\Amplitude is different for I and Q.
    \item[Quadrature Error] \hfill \\Phase between I and Q is not \ang{90}.
    \item[IQ Offset] \hfill \\I and Q are not centered at zero.
    \item[Gain Compression] \hfill \\Distance $d$ between constellation points is power dependent.
    \end{description}

  \end{columns}
\end{frame}
}

\end{document}

enter image description here

share|improve this answer
    
Thanks! For some reason it didn't work for me, I've uploaded a screenshot of my slide. –  LWZ Sep 8 '13 at 22:35
    
@LWZ A screenshot in this situation is useless; please provide the code producing that result. –  Gonzalo Medina Sep 8 '13 at 22:36
    
Sorry, I've uploaded the code now, adding \setbeamersize{description width=-\labelsep} before the frame did not make any difference. –  LWZ Sep 8 '13 at 22:45
    
@LWZ of course it didn't since you are using \begin{description}[leftmargin=0pt] delete [leftmargin=0pt]. –  Gonzalo Medina Sep 8 '13 at 22:47
1  
@LWZ no problem! I added some other modifications to your code in my updated answer; perhaps they can also be useful for you. –  Gonzalo Medina Sep 8 '13 at 22:54

if you use the enumitem package you are able to adjust every parameter of the lists.

to achieve what you want, you need the itemindent and the leftmargin parameter

\documentclass{article}
\usepackage{enumitem}

\begin{document}

   \begin{description}[nosep,itemsep=0pt,leftmargin=0pt]
      \item[Counterfactual Test]\hfill\\
      Kann ein Kaugummi erhalten werden, wenn sich kein Kaugummi im Automaten befindet?
   \end{description}
\end{document}

enter image description here

share|improve this answer
    
This works, but it changed the color of \item[]. I'm using it in beamer so I would like to keep the color. –  LWZ Sep 8 '13 at 19:21
    
@LWZ: I've added the beamer to your question, since it seem relevant. Also relevant: Does enumitem conflict with beamer for lists? –  Werner Sep 8 '13 at 19:31
    
Thank you! Seems like it's better to have another way other than using enumitem. –  LWZ Sep 8 '13 at 19:37
    
@LWZ: Well i did not know you're using beamer, if anyone wants to add a solution working with beamer I'll delete mine –  Rico Sep 8 '13 at 19:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.