Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using custom.bib to create my own citation stile, and I quite like the result!

The only thing I couldn't find, was how I can change some things in the citations in the text. What I miss, is the possibility to reduce the cited name only to the surname

(Mueller, 2012)

or change the bracket style to these brackets [].

Now it is only like this

(Johannes Mueller, 2012)

which I think is too long.

If you can give me the solution right away I'd be glad, but I also want to know how to change some things of the custom.bib file afterwards by myself and without having to ask every single time.

Edit:

A test file, the edited .bst file and the used .bib file here: https://drive.google.com/folderview?id=0B07uks0ZD0GGUTROd1o4MW1WNG8&usp=sharing

Additionally to say. I'm using LyX and I've activated the natbib package in there and set as option author-year. But I must say it now, that I concentrated a bit more on it, it behaves very strange... LyX doesn't accept any options like square for square brackets. They do appear if i use the standard (numerical) option on LyX. If I switch too much between the processor (bibtex8/bibtex/biber/standart) it refuses to do anything and just shows

???

What the heck? I mean, is this behavior normal with LyX? I don't feel confident enough to switch to LaTeX because I just can't handle so much code :/

share|improve this question
    
Welcome to TeX.SX! –  Papiro Sep 10 '13 at 9:05
    
For BibTeX and modifications look at tame the beast. For specific modifications to your style we would need to see it. For more possibilities and easier modifications you might like biblatex. –  moewe Sep 10 '13 at 9:07
2  
Normally, natbib should not include the author's first name in an authoryear-style citation. There may be something amiss either with the way you enter the information in the author field or some other aspect of the document related to creating citations. Please edit your posting to (i) show a representative bib entry and (ii) provide a complete MWE (minimum working example) that generates the problem behavior you're looking to solve –  Mico Sep 10 '13 at 10:53
    
Done! Tame the beast seems to be whole lot of work to get through (man I wish I was a English mother tongue guy), I hope I have the time. Maybe I did a little fault there... I was using tex makebst, is it right that this is part of custombib? –  Lukas Sep 10 '13 at 14:03
    
I would suggest limiting this post to one question, and start another for further problems. Perhaps revert this to just being about reference styles, and start a new one about problems using Lyx? –  CPLB Sep 11 '13 at 9:08

1 Answer 1

up vote 0 down vote accepted

To change the parentheses to brackets, you can use the natbib package. You can specify square as an option to the package, or for control of other features too, use the bibpunct command, there is an example on this reference sheet.

I believe that only using the surname is the default way of referencing. Having looked at your .bib, I think the issue may be that you have author names stored as firstname secondname rather than secondname, firstname.

In your .bib, the entry is

@BOOK{Palgrave2002,
  title = {{T}rees of {S}outhern {A}frica},
  publisher = {4 {R}andom {H}ouse {S}truik ({P}ty) {L}td},
  year = {2002},
  editor = {{L}eni {M}artin},
  author = {{K}eith {C}oates {P}algrave},
  pages = {1212},
  address = {Cape Town - South Africa},
  edition = {Third},
  owner = {Lukas Koch},
  timestamp = {2013.02.25}
}

Here you can see the author field which needs to be changed to {{P}algrave, {K}eith {C}oates}. (I expect that {Palgrave, Keith Coates} would work fine too). I would expect that most reference managers should be able to handle this and it shouldn't be too hard to figure out.

share|improve this answer
    
Has it something to do with the fact that I'm using LyX maybe? taking cover –  Lukas Sep 10 '13 at 14:14
    
Hm, I'm using JabRef to sort my sources and the only thing I have found there, that could fit to your remarks: Jabref preferences->Entry table->Format of author[...]-> I have ticked "natbib style", 'Show "Lastname, Firstname"' ticked and then "Show last names only" made no difference... –  Lukas Sep 10 '13 at 14:47
    
To be honest, I have no idea how you got this information from the .bib file. Where is this standing and how can I change it? (Preferably with JabRef) –  Lukas Sep 10 '13 at 19:48
    
When I change it manually, it works for me, at least the problem, that only surnames should appear... I have yet to figure out how JabRef uses this format as default. Thanks! –  Lukas Sep 11 '13 at 7:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.