Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I m using Biblatex with polyglossia and although I set german as my default language, the bibliography shortcuts are still in english. Here is a minimal working example:

\begin{filecontents*}{literatur.bib}

@article{Grothendieck,
author = {Grothendieck, A.},
title = {Sur quelques points d'algebre homologique, I},
language = {fr},
journal = {Tohoku Mathematical Journal},
volume = {9},
year = {1957},
pages = {119-221},
}
\end{filecontents*}

\documentclass{article}
\usepackage[babelshorthands]{polyglossia} 
\setdefaultlanguage[spelling=new,latesthyphen=true]{german} 
\usepackage[style=alphabetic,backend=biber,maxnames=5,maxalphanames=5,backref=true,backrefstyle=two+]{biblatex}
\renewbibmacro{in:}{}
\DefineBibliographyStrings{german}{%
 backrefpage = {zit. auf S.},
 backrefpages = {zit. auf S.},
 }
 \bibliography{literatur}

\begin{document}
This is a citation of \cite{Grothendieck}.
\printbibliography
\end{document}

With this I get "pp." instead of "S." and "cit. on p." instead of "zit. auf S.". How can I fix that? Thanks in advance.

share|improve this question
    
Joseph Wright of the biblatex team has just worked out why the polyglossia support didn't work properly. I have just incorporated his fix into the biblatex 2.8 DEV version on SF if you would like to try it (and leave a comment on the github issue for this - github.com/plk/biblatex/issues/69) –  PLK Sep 28 '13 at 12:55
add comment

1 Answer 1

up vote 6 down vote accepted

biblatex has removed the support for polyglossia (probably because of a bug which appeared some time ago). Either use \usepackage[ngerman]{babel} (it will work fine with XeLaTeX/luaLaTeX), or use language=german in the options of biblatex.

share|improve this answer
    
Thank you, Ulrike. That work's fine. –  Lisa Sep 11 '13 at 8:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.