Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Normall microtype tracking loosens the tracking of small caps. However, with fontspec's \setmainfont{ebgaramond}, small caps are completely disabled and I get a loose normal text,

enter image description here

as opposed to

enter image description here

with the corresponding font package and normal pdfLaTeX. I want to use LuaLaTeX for some fancy ligatures, and XeLaTeX messes everything up.

Using the ebgaramond package in LuaLaTeX doesn't help.

share|improve this question
    
microtype doesn't go well with luaLaTeX. –  Harish Kumar Sep 12 '13 at 0:04
    
@HarishKumar Is there a way to loose-track small caps outside of \usepackage[tracking]{microtype} but while not interfering with microtype's other duties? In other words, can I achieve this effect while keeping microtype for my other stuff? –  Simon Kuang Sep 12 '13 at 0:06
    
There is beta version of microtype but I am not sure as to what extent it is good. I don't have much experience with lua. Let us wait for luatexperts :-) –  Harish Kumar Sep 12 '13 at 0:23
2  
You need to load the font with Renderer=Basic (see here). The upcoming version of microtype will also work with the Full renderer. –  Robert Sep 12 '13 at 17:12
    
This is also the same problem. Duplicate? –  Robert Sep 12 '13 at 17:20

1 Answer 1

up vote 12 down vote accepted

If you provide the instruction

\defaultfontfeatures{SmallCapsFeatures={Renderer=Basic}}

then the tracking option of the microtype package seems to work correctly:

enter image description here

% !TEX TS-program = lualatex
\documentclass{article}
\usepackage{fontspec}
\defaultfontfeatures{SmallCapsFeatures={Renderer=Basic}}
\setmainfont{EB Garamond}
\usepackage[tracking=true]{microtype}
\begin{document}
\textsc{Christianity} Christianity
\end{document}
share|improve this answer
    
You are not using tracking in the example. –  Robert Sep 12 '13 at 17:16
    
@Robert - Thanks for pointing this out. Adding the instruction \defaultfontfeatures{SmallCapsFeatures={Renderer=Basic}} seems to do the job if tracking is enabled. I'll update my example accordingly. –  Mico Sep 12 '13 at 18:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.