Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I run a tex file containing \renewcommand*{\sideparfont}{\small\itshape} on my MacBook it works perfectly but when I am running it on my Ubuntu 10.10 machine I get: !LaTeX Error: \sideparfont undefined. I just upgraded my Ubuntu machine to the latest version so it feels unlikely that it should be a too old version but then again maybe that is it?

If so, how can I get a version where this works? (It says it is version: pdfTex 3.1415926-1.40.10-2.2 (TeX Live 2009/Debian))

share|improve this question
1  
It's well-known that Linux distributions are well behind TeX Live development: see posts here and elsewhere. If you want to work using up-to-date LaTeX packages, you'll need to install TeX Live 2010 outside of Ubunutu's package manager. (It's not hard!) –  Joseph Wright Mar 13 '11 at 14:12
    
I guess not but it's very sad and I am very suprised about this to be honest. :( –  jonalv Mar 13 '11 at 14:18
    
The Debian packagers have their own approach to TeX Live, which is based on how many other projects work (stable code is older code). The way (La)TeX packages on CTAN work, this is not really a great assumption, in my opinion, but that is of course up to them. –  Joseph Wright Mar 13 '11 at 14:22
    
Do you think this question should have the "ubuntu" tag? –  Seamus Mar 13 '11 at 14:26
    
Yea that makes sense. I added it... –  jonalv Mar 13 '11 at 17:38
add comment

3 Answers

up vote 6 down vote accepted

The version of TeXlive in the ubuntu repositories is quite old. You probably have an older version of memoir on ubuntu than you do on your mac.

The best option is probably to uninstall the packaged version of TeXlive and install TL2010 from TUG directly.

Otherwise, you can install a newer version of memoir in your local texmf. Here's how.

First download the memoir.tds.zip. This is a packaged version of memoir in the TeX Directory Structure. Now move the file to your local texmf which should be ~/texmf/ on Ubuntu. Now unzip the file to that directory.

You might have to then run sudo texhash ~/texmf (I can't remember). You should now have a working version of the newest memoir. Unfortunately, this means you'll have to keep an eye out for new versions yourself. Which is why installing TL2010 from TUG is the much better option...

share|improve this answer
    
For something like memoir, I'm not sure how well the tds option will actually work. You may find that it will complain about other package mismatches, and you might have to install several other packages in the same way before it will work. This was my experience with other "big" packages like siunitx and biblatex –  Seamus Mar 13 '11 at 14:25
    
At least in the siunitx case, I always try to be explicit that you have to have the matching LaTeX3 support. I think biblatex is similar with respect to etoolbox. In almost all cases, users don't install directly but via their (TeX) package manager, so this is not usually an issue. –  Joseph Wright Mar 13 '11 at 17:20
    
@Joseph I agree that using tlmgr is unequivocally the best way to do it. It wasn't a criticism of siunitx, just a warning that doing things this TDS route can lead to more installations... –  Seamus Mar 13 '11 at 17:49
add comment

On a Debian-derived system, another package with a dependency on the distribution's texlive packages may install parts or all of their version, and now you have two of them present, and have to take pains to make sure you don't get them mixed up.

So you might just want to avoid the distribution's version entirely. I haven't done it yet, since I'm happy with their installed versions so far, but I may have to do that in the future.

This post looks about right, and links to a TUG page about getting the correct equivs settings. Reposted, in case the link goes dead later:

  • Download and unpack TL2010 installer
  • sudo ./install-tl
  • Select option "Create symlinks to standard directories"
  • Start installation of TeX Live
  • Test TeX Live with pdflatex test where test.tex is a minimal LaTeX document => ok
  • sudo apt-get install perl-tk perl-doc equivs
  • Create and install texlive-local_2009-1_all.deb (see http://www.tug.org/texlive/debian.html)
  • sudo apt-get install texworks (this should NOT install any TeX related packages except texworks => ok)
  • Test TeXworks => ok
  • sudo tlmgr update --self --all => ok
  • sudo tlmgr gui, install an additional package, re-create format files, ... => ok
share|improve this answer
add comment

When in doubt about a version, add \listfiles at the beginning of your document (before \documentclass) and you'll find a nice summary of the packages and files used with their respective versions at the end of the log file. This way, you can easily confirm which packages/classes are more up-to-date on one machine than the other.

Besides, it can help for asking more precise questions or reporting bugs in a particular version of some package.

share|improve this answer
    
\listfiles doesn't need to go before \documentclass does it? It works fine anywhere in the preamble... –  Seamus Mar 13 '11 at 20:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.