Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just needed to compile the following lines (minimal example)

\documentclass{standalone}
\listfiles
\usepackage{pstricks}
\begin{document}
Ein
\begin{pspicture}(-5,-3)(5,8)
\psline(0,1)(2,3)
\end{pspicture}
Test
\end{document}

But that went wrong. I'm sorry - but I can only ask for help here - because I'm not able to see any problem in there.
As tug.org/PSTricks reads, it should work fine directly with XeLaTeX.
I'm using TexLive2010.
For further description, here is the output of xelatex test | grep pstricks

(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/latex/pstricks/pstricks.st
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/generic/pstricks/pstricks.
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/generic/pstricks/pst-fp.te
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/xelatex/xetex-pstricks/pst
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/generic/pstricks/config/xd
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/xelatex/xetex-pstricks/pst
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/generic/pstricks/config/xd
(/home/ebeling/usr/local/texlive/2010/texmf-dist/tex/generic/pstricks/pst-fp.te
Error: /invalidfileaccess in --run--
Operand stack:
   (/home/ebeling/usr/local/texlive/2010/texmf-dist/dvips/pstricks/pstricks.pro)   (r)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1878   1   3   %oparray_pop   1877   1   3   %oparray_pop   1861   1   3   %oparray_pop   1755   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1878   1   3   %oparray_pop   --nostringval--
Dictionary stack:
   --dict:1161/1684(ro)(G)--   --dict:0/20(G)--   --dict:70/200(L)--
Current allocation mode is local
Current file position is 82
GPL Ghostscript 8.71: Unrecoverable error, exit code 1

** WARNING ** Filtering file via command -->ps2pdf -dCompatibilityLevel=1.5 -sPAPERSIZE=a0 -dAutoFilterGrayImages=false -dGrayImageFilter=/FlateEncode -dAutoFilterColorImages=false -dColorImageFilter=/FlateEncode '/tmp/dvipdfmx.XXSJ7G06' '/tmp/dvipdfmx.XXaj80iD'<-- failed.
** WARNING ** Image format conversion for PSTricks failed.
** WARNING ** Interpreting special command pst: (ps:) failed.
** WARNING ** >> at page="1" position="(160.635, 85.5393)" (in PDF)
** WARNING ** >> xxx "pst:  tx@Dict begin STP newpath /ArrowA { moveto } def /ArrowB "
pstricks.sty    2010/09/18 v0.48 LaTeX wrapper for `PSTricks' (RN,HV)
pstricks.tex    2011/01/30 v2.17 `PSTricks' (tvz,hv)

The other lines do not show up more details.
Thanks for any help.

share|improve this question
    
I just tried to compile with xelatex -no-pdf and that worked fine. Convert via xdvipdfmx throws the same error lines. –  Bastian Ebeling Mar 14 '11 at 8:14
    
Hmmm, seems to work fine for me. I'm using TL2010 on Linux with GhostScript 8.71. My log file contains the line 'Using PSTricks configuration for XeTeX+xdvipdfmx'. –  Andrew Stacey Mar 14 '11 at 8:29
    
@Andrew: did you run tlmgr --self --all update before? –  Herbert Mar 14 '11 at 8:41
    
@Herbert: No, I didn't. I presume from your comment that this would that have introduced the problem. That's useful to know for the context of the error. –  Andrew Stacey Mar 14 '11 at 8:56
    
@Bastian: It's not necessary to sign your questions (as there is already a box with your username below it) or to begin them with a greeting. –  Hendrik Vogt Mar 14 '11 at 13:41
show 2 more comments

1 Answer

up vote 9 down vote accepted

Herbert Voss wrote in an answer to a similar question in c.t.t.:

edit the file .../texlive/2010/texmf/dvipdfmx/dvipdfmx.cfg to insert the option -dNOSAFER into the line with ps2pdf

D  "ps2pdf -dCompatibilityLevel=%v -dNOSAFER -sPAPERSIZE=a0 ...

without -dNOSAFER ghostscript can't run external files

share|improve this answer
    
I have tried this in MikteX, but with no success. The file is at C:\Program Files (x86)\MiKTeX 2.9\dvipdfm\config\dvipdfmx.cfg, and the invocation seems to be for "mgs.exe", or "MikteX's gs". I inserted -dNOSAFER, saved, but saw no difference. Maybe that isn't the right file, or there is some other refresh operation that must take place, because commenting out the entire line also made no difference. –  Leo Mar 5 at 19:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.