Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have problem having IEEE copyright notice and Conference header both at the same time in the first page of my paper that uses IEEE Trans class.

I notice that \thispagestyle{fancy} makes the copyright notice disappear! when I comment it, I have copyright notice back but I miss the first page header (header starts from second page).

my code is:

\documentclass[10pt, conference]{IEEEtran}
\IEEEoverridecommandlockouts

\usepackage{graphicx}
\usepackage{newlfont}
\usepackage{multicol}
\usepackage{multirow}
\usepackage[table]{xcolor}
\usepackage{tabularx}
\usepackage{cite}
\usepackage{amssymb}
\usepackage[cmex10]{amsmath}
\interdisplaylinepenalty=2500
\usepackage{array}
\usepackage{stfloats}

\usepackage{lipsum}

\usepackage{fancyhdr}
\setlength{\headheight}{15.2pt}
\pagestyle{fancy}
\renewcommand{\headrulewidth}{0pt} % no line in header area
\fancyhead{}
\chead{12$^{th}$ Iranian Conference on Intelligence Systems, 4-6 February 2014, Bam, Iran}
\fancyfoot{}

\begin{document}
\title{Paper Title Goes Here.}


\author{
\IEEEauthorblockN{Author1}
\IEEEauthorblockA{
Dept. of Math and Computer Science\\
Higher Education Complex of Bam \\
Kerman, Iran \\
E-mail:author1@uk.ac.ir.
}
\and
\IEEEauthorblockN{Author2}
\IEEEauthorblockA{
Dept. of Math and Computer Science\\
Shahid Bahonar University\\
Kerman, Iran \\
E-mail: auhtor2@uk.ac.ir}
\and
\IEEEauthorblockN{Author3}
\IEEEauthorblockA{
E-mail: author3@gmail.com}
}

%%%%
\IEEEpubid{
  \makebox[\columnwidth][l]
  {\hfill
978-1-4799-1228-5/13/\$31.00~\copyright~2013 IEEE
  }
  \hspace{\columnsep}
  \makebox[\columnwidth]{}
}

\maketitle

\begin{abstract}
put your abstract in here...
\end{abstract}
\begin{IEEEkeywords}
semantic web, Internet, Security
\end{IEEEkeywords}

%%% This line removes the copyright notice!!!
\thispagestyle{fancy}

\section{First}
\lipsum[1]
\section{Second}
\lipsum[2-10]
\end{document}

output with \thispagestyle{fancy}. header:yes copyright:no enter image description here

output without \thispagestyle{fancy}. header:no copyright:yes enter image description here

Any suggestion is appreciated. My last paper got published with this bug. no one noticed that! I don't want IEEE to reject publishing my next paper because of this stupid bug.

share|improve this question
    
Header means? Where it appears? –  tex Sep 21 '13 at 5:43
    
@tex Header mean header! simple header goes above the pages. fancyhdr package creates header and footer. I used it. let me add the output picture to my post. –  sajjadG Sep 21 '13 at 5:47
    
Are you sure conference papers need headers like this. I have send papers without heaqdings, since the IEEE manual says so. From the manual "Conference papers do not have running headings" –  tex Sep 21 '13 at 6:34
    
The headers are added by the conference publication office automatically. you only need to use the template ieeeconf –  percusse Sep 21 '13 at 7:36
    
@percusse I am trying to make a template for a conference! I think I'm the only one who use it at last :) –  sajjadG Sep 21 '13 at 12:52
add comment

2 Answers

up vote 2 down vote accepted

If the organizers of an IEEE sponsored conference want headers like this for their conference papers, they must have their own way to include them that is compatible with the IEEEtran class. I can't imagine they have suggested using the fancyhdr package, which conflicts with IEEEtran. @Werner's solution works but effectively overrides IEEEtran headers.

The conference option of IEEEtran removes running headers from your paper. This was their choice, I guess, and normally that should be respected --- they're the publishers and they should get what they want (or they should make sure that they implement what they want in the IEEEtran class that they provide).

If you have to use the conferece option and you absolutely want to have a running header, both in the first page and in all other pages, then I suggest that you get rid of the fancyhdr package and that you add something like the following to your preamble:

\makeatletter
\let\old@ps@headings\ps@headings
\let\old@ps@IEEEtitlepagestyle\ps@IEEEtitlepagestyle
\def\confheader#1{%
  % for all pages except the first
  \def\ps@headings{%
    \old@ps@headings%
    \def\@oddhead{\strut\hfill#1\hfill\strut}%
    \def\@evenhead{\strut\hfill#1\hfill\strut}%
  }%
  % for the first page
  \def\ps@IEEEtitlepagestyle{%
    \old@ps@IEEEtitlepagestyle%
    \def\@oddhead{\strut\hfill#1\hfill\strut}%
    \def\@evenhead{\strut\hfill#1\hfill\strut}%
  }%
  \ps@headings%
}
\makeatother

\confheader{%
  12$^{th}$ Iranian Conference on Intelligence Systems,
  4-6 February 2014, Bam, Iran
}

Also, I suggest that you end your lines with % in your \IEEEpubid, unless you want the copyright notice not to be right-aligned properly with the left column.

\IEEEpubid{%
  \makebox[\columnwidth][l]%
  {\hfill%
978-1-4799-1228-5/13/\$31.00~\copyright~2013 IEEE%
  }%
  \hspace{\columnsep}%
  \makebox[\columnwidth]{}%
}
share|improve this answer
    
You're right. Getting rid of fancy header is better. and +1 for your note on using % at the end of those lines. I still don't get it! % is for comment but here it seems to act like a command or something! –  sajjadG Sep 21 '13 at 12:49
1  
The newline generally counts as a space in the bodies of macros. If you don't want that, adding a % after the last character treats the rest of the line as a comment. This saves you of that space (and ignores leading spaces on the next line too). –  nickie Sep 21 '13 at 13:44
add comment

fancyhdr conflicts with (or overrides, rather) the header/footer setting of the IEEEtran class. You could, however, add the lines

\makeatletter
\fancyfoot[L]{%
  \normalfont\footnotesize%
  \raisebox{\footskip}[1.5ex]{%
    \makebox[\columnwidth][r]{978-1-4799-1228-5/13/\$31.00~\copyright~2013 IEEE}}}
\makeatother

to your preamble. This inserts the copyright content in the [L]eft footer, raised up into place within the left column. However, you will have to set another page style that excludes this from page 2 onward. So, perhaps page 1 could use \thispagestyle{fancy}, while the rest of your document could use \pagestyle{nocopyright}, where you

\fancypagestyle{nocopyright}{%
  % <header similar to fancy>
  % <footer only page # in centre>
}

This is something you need to sort out with the journal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.