Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have tried following this answer, but it gives me:

xelatex.exe: Invalid command-line option

xelatex.exe: Data: unknown option

Shell-escape is required for minted, and is enabled for XeLaTeX using -enable-write18.

What I write in LaTeX include articles with BiBTeX references. Here is the usual format I take:

\documentclass[conference]{IEEEtran}
\usepackage{cite}
\usepackage{epstopdf}
\usepackage[cmex10]{amsmath}
\usepackage{filecontents}
\begin{filecontents*}{references.bib}
@phdthesis{michael_power_1991,
    title = {The Power of Two Choices in Randomized Load Balancing},
    url = {http://www.eecs.harvard.edu/~michaelm/postscripts/mythesis.pdf},
    school = {Harvard},
    author = {Michael David Mitzenmacher},
    year = {1991}
}
}
\end{filecontents*}

\bibliographystyle{plain}
\bibliography{references}
\end{document}

How do I add PDF rendering support for these typeset requirements within TeXworks?

share|improve this question
add comment

2 Answers

latexmk has a switch called -shell-escape that should do what you want. It takes care of makeindex and bibtex anyway.

so this should work

Name: xelatexmk
Program: latexmk

Arguments: -xelatex
           -shell-escape
           -e
           $synctexoption %O %S/
           $fullname
share|improve this answer
    
Unfortunately that didn't work, got this error when trying to run it: pastebin.com/8KzsfE9V (FYI: I removed all comments in my file just to be sure), I'm guessing it has something to do with: $synctexoption %O %S/ –  A T Oct 10 '13 at 10:21
add comment

I am not sure what exactly you are using, but the command XeLaTeX+MakeIndex+BibTeX in TeXworks (at least my configuration) actually calls texify instead of miktex-pdftex, so the option needs just a small addition.

Based on this: How to use PSTricks with PDF Texify in WinEdt?

Add the desired option as following:

--tex-option=--enable-write18
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.