Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just upgraded my TeX Live installation on Ubuntu 64-bit from 2012 to 2013. After the upgrade, when I tried to render some simple 3D drawings I was not getting the default rendering window to come up. So from the Asymptote manual I added the following lines:

import settings;
outformat="";
render=-1;

I get the following error:

$ asy -V 3test.asy
 /usr/local/texlive/2013/texmf-dist/asymptote/three.asy: 2906.13: runtime: to support onscreen rendering, please install glut library, run ./configure, and recompile

In TeX Live 2012, even without the suggested configuration options, a command such as the one used above would go right into the OpenGL renderer.

Any suggestions as to what is going on? I am thinking that perhaps the Asymptote that is compiled into TeX Live 2013 is compiled without the glut libraries? Do I need to compile Asymptote directly from source?

share|improve this question
    
For what it's worth, I have not had any trouble with Asymptote using MacTeX 2013 (the packaging of TeX Live 2013 for mac). –  Charles Staats Oct 2 '13 at 2:50

1 Answer 1

Assumption

I guess that you installed "vanilla" TeX Live 2013 from CTAN as explained on the following question How to install "vanilla" TeXLive on Debian or Ubuntu?

For a next time tell also what version of Ubuntu you installed - e.g. Ubuntu 12.04 Longtime-support.

Requirement of OpenGL/Glut

Check what packages you installed already. I had to install the package freeglut3-dev:

$ apt-get install freeglut3-dev
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.