Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have downloaded the zip file from http://mirror.ctan.org/fonts/urw/classico/uop.zip and unzipped the content into /usr/local/texlive/texmf-local/ and then run:

$ sudo texhash
texhash: Updating /usr/local/texlive/2010/../texmf-local/ls-R... 
texhash: Updating /usr/local/texlive/2010/texmf/ls-R... 
texhash: Updating /usr/local/texlive/2010/texmf-config/ls-R... 
texhash: Updating /usr/local/texlive/2010/texmf-dist/ls-R... 
texhash: Updating /usr/local/texlive/2010/texmf-var/ls-R... 
texhash: Done.

Followed by:

$ sudo updmap-sys --enable Map=uop.map
updmap: This is updmap, version $Id: updmap 17423 2010-03-11 17:53:34Z karl $
updmap: using transcript file `/usr/local/texlive/2010/texmf-var/web2c/updmap.log'
updmap: initial config file is `/usr/local/texlive/2010/texmf-config/web2c/updmap.cfg'
updmap: configuration (updmap.cfg) unchanged. Map files will not be recreated.

However when I try using \renewcommand*\sfdefault{uop} I get:

[...]
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+432/600 --dpi 432 uopr8r
mktexpk: don't know how to create bitmap font for uopr8r.
mktexpk: perhaps uopr8r is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

!pdfTeX error: pdflatex (file uopr8r): Font uopr8r at 432 not found
==> Fatal error occurred, no output PDF file produced!
[...]

It feels wrong that updmap-sys said: configuration (updmap.cfg) unchanged. Map files will not be recreated. But I feel that I have followed the instructions and don't know what I can do differently. Can anyone help me with this?

share|improve this question
    
Oh, btw I might have run the updmap-sys command once before with stuff placed in the wrong location but I would imagine it possible to re-run it. –  jonalv Mar 16 '11 at 17:49
    
Does the file /usr/local/texlive/2010/texmf/web2c/updmap.cfg contain the line Map uop.map? –  Michael Ummels Mar 16 '11 at 18:12
    
Also, is there a file called updmap.cfg in ~/Library/texlive/2010/texmf-config/web2c/? –  Michael Ummels Mar 16 '11 at 18:14
    
No the file /usr/local/texlive/2010/texmf/web2c/updmap.cfg does not contain Map uop.map. As for the other thing I don't even have a Library/texlive folder, and according to the output of updmap-sys in my question it looked for and found such a file at /usr/local/texlive/2010/texmf-config/web2c/updmap.cfg isn't that enough? –  jonalv Mar 16 '11 at 18:23
    
Can you manually add the line Map uop.map to /usr/local/texlive/2010/texmf-config/web2c/updmap.cfg and then run sudo updmap-sys? –  Michael Ummels Mar 16 '11 at 18:34
show 8 more comments

1 Answer 1

up vote 2 down vote accepted

In general the source of this problems is a mix of updmap-sys and updmap commands. updmap creates local map-files (and I think also cfg-files) which hides the system wide map-files created by updmap-sys.

You could at first try to disable and then to reenable the map-file to force updmap-sys to generate map-files. Then check if you document actually use this new map-file.

share|improve this answer
    
Sounds like a good idea but how do I do that? sudo updmap-sys --disable Map=uop.map gives me the same message... Why wouldn't the document use the map-file? And how to check that? This answer generates more questions than it answers... :/ –  jonalv Mar 16 '11 at 18:11
    
Looking at your pathes above it looks as if the installation folder /usr/local/texlive/texmf-local/ is not in the texhash list. Are you sure you did put the files in the correct tree? –  Ulrike Fischer Mar 16 '11 at 18:26
    
I think it is in the list: it is the first entry. –  Michael Ummels Mar 16 '11 at 18:33
    
Actually, no I am not sure... However I know I am supposed to place them in a tree with the root in a folder named texmf-local and the folder /usr/local/texlive/2010/ does not contain such a folder. Which makes sense since as I understand things the point of the texmf-local is that it should be used for files that should be migrated the day I switch to version 2011. So if it is not the texmf-local folder in the root that contains the 2009 and 2010 versions then where else could the correct tree be? –  jonalv Mar 16 '11 at 18:37
1  
Sorry I wrote nonsense. /usr/local/texlive/2010/../texmf-local/ is /usr/local/texlive/texmf-local/. Run a small document with pdftex and check at the end of the log-file the path of the pdftex.map. –  Ulrike Fischer Mar 16 '11 at 18:49
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.