Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use chemfig to draw a basic schematic for enzymatic browning and have encountered a problem. In the bottom reaction (bottom right to bottom left) quinone is formed by the enzyme (denoted by the bracket underneath). The anchor for the curved arrow, however, seems to be incorrectly placed and try as I might I have not been able to solve the problem. I've tried flipping it every which way to no avail. Any tips?

\documentclass{article}

\usepackage{chemfig}
\setatomsep{2em}
\setbondoffset{0.5pt}
\setarrowdefault{,1.5,}

\begin{document}

\begin{figure}
\schemedebug{true}
\schemestart
\chemup.\chemfig{N-[:30]Cu-[:150]N}\qquad\chemfig{N-[:150]Cu-[:30]N}\chemdown]
\arrow{-U>[*{0.0}{\chemfig{O_2}, \chemfig{H_2O}}]}[90,2]
\chemup.\chemfig{N-[:30]Cu(-[:150]N)(-[:90,,,2,]H_2O)-[:30]O-O-[:-30]Cu(-[:90]OH_2)(-[:30]N)-[:-30]N}\chemdown]
\arrow{-U>[\chemfig{**6([,0.5]----(-OH)--)}][\chemfig{H_2O}]}[0]
\chemup.\chemfig{N-[:30]Cu(-[:150]N)(-[:90]O-[:30]**6([,0.5]------))-[:30]O-O-[:-30]Cu(-[:90]OH_2)(-[:30]N)-[:-30]N}\chemdown]
\arrow{-U>[*{0.180}2\chemfig{H^+}][*{0.180}\chemfig{H_2O}]}[-90]
\chemup.\chemfig{N-[:30]Cu(-[:150]N)-[:30]O-[:90]**6([:60,0.5]-(-[:-90,1]O-[:-30,1]Cu(-[:30,1]N)-[:-30,1]N)-----)}\chemdown]
\arrow{-U>[][*{0.north}\chemfig{*6([:-30,0.5]-(=[:-120]O)-(=[:-60]O)-=-=)}]}[180,1.85]
\schemestop
\end{figure}

\end{document}

enter image description here

share|improve this question

1 Answer 1

I do not see that when I compile your MWE. The anchor is at its normal place (i.e. above the ring and not inside it). Pershaps your latex distribution needs an update?

enter image description here

share|improve this answer
    
I actually just reinstalled MiKTeX 2.9.4813 (for this and unrelated reasons) and I'm still getting the same result. I'm using TeXstudio and compiling with XeLaTeX, if either of those could be contributing factors. –  Dre Oct 9 '13 at 19:48
    
I use linux+texlive13 and the result remains the same with xelatex. I'm afraid I can't help you because I do not have windows and I never runned miktex. –  unbonpetit Oct 9 '13 at 19:54
    
Thanks anyways. I'll continue fiddling with it and see if I can get any result. –  Dre Oct 9 '13 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.