Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using LaTeX, and I have a large table in my report, the height of table is a little more than half of the paper. all the text after the table will go to the next page, and in this page just the table remain and a lot of space after and before the table!

share|improve this question

migrated from stackoverflow.com Mar 18 '11 at 13:41

This question came from our site for professional and enthusiast programmers.

    
Hi mary, welcome to TeX.SX, the stack exchange site for TeX, LaTeX and friends. Your question was migrated here and I adjusted the title to better fit to the page. –  Martin Scharrer Mar 18 '11 at 14:02
    
How exactly are you coding the table? Are you using the normal approach of a tabular inside a table environment or something different? –  Martin Scharrer Mar 18 '11 at 14:04

2 Answers 2

This line will solve your problem:

\renewcommand{\floatpagefraction}{0.8}

If it is a double column paper, you may need this instead/as well:

\renewcommand{\dblfloatpagefraction}{0.8}
share|improve this answer

Your table is too large to fit onto a normal page of text and is therefore placed on a "float page", i.e. a page which only contains material from table and figure (or custom defined) float environments.

If you want to place such a large table on a normal page you can either modify the appropriate settings (see How can I get the figures not to be pushed to the end of the document?). Increasing the \floatpagefraction already mentioned by Forrest allows larger tables on normal text pages. It states which fraction of the page a table or figure can consume before placed on an extra page. You can also add ! into the optional placement specifier of the table environment, i.e. \begin{table}[!ht], to overwrite/ignore this settings for the specific table.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.