Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use TikzEdt tool to generate some graphs....It was working very nicelly, until I tried the extended mode, and from that instance, it is reporting an error. Here is the preamble

\documentclass[fleqn]{article}
\usepackage{tikz,amsmath, amssymb,bm,color}
\usepackage[margin=0cm,nohead]{geometry}
\usepackage[active,tightpage]{preview}
\usetikzlibrary{automata,positioning}
\usetikzlibrary{shapes,arrows}
% needed for BB
\usetikzlibrary{calc}   
%% Begin Added by me
\usepackage{pdfpages}       %To be able to insert PDF pages   
\usepackage{pgfplots}    
%% End of added by me
\PreviewEnvironment{tikzpicture}

and here is a very basic code

% Define block styles    
\tikzstyle{line} = [draw, -latex']  

\begin{tikzpicture}[node distance = 2cm,auto]
    % Place nodes
    \node [draw,rounded corners] (node1) {node1};

\end{tikzpicture}

I tried (Re-)Generate Precompiled headers and this is what I get:

Generating precompiled header: pdflatex -ini -jobname="temp_header" "&pdflatex temp_header.tex\dump"
Compilation of pre-compiled header failed with exit code 1. Compilation of main document stopped. Check that all necessary packages are installed and that the pre-compiled header code (in the settings) has no errors!

A file named temp_header.auxlock is generated containing one single line \def \tikzexternallocked {0} Can any one please suggest some help?

share|improve this question
    
And how did you try to enter extended mode in tikzedt?. I think you are trying to overuse tikzedt. It is meant primarily to draw tikz pictures and not for writing articles. Please try some other LaTeX editors. –  Harish Kumar Oct 15 '13 at 7:17
    
Your additions work fine for me. However you can try with (Re-)Generate precompiled headers in Compilation menu. –  Harish Kumar Oct 15 '13 at 7:51
    
@HarishKumar, I am not using it for documents, but only for graphs....The regeneration also gave an error (see thread update)...As for your question, with a given document, the number of points exceeded the limit, so, I've read somewhere that one has to enter the extended mode. Didn't work, so I had to reduce the number of points..but now, nothing is working. –  user2536125 Oct 15 '13 at 9:03
    
Instead of trying to modify the precompiled header, you can use standalone option of tikzedt`. In the side bar,look for standalone and in that standalone document. –  Harish Kumar Oct 15 '13 at 9:44
    
@HarishKumar can you please include a snapshot? my TikzEdt seems not to have the standalone version... –  user2536125 Oct 15 '13 at 10:17
show 2 more comments

1 Answer

up vote 1 down vote accepted

I figured out the solution with the help of a friend. in the directory ...C:\Users\username\AppData\Roaming\TikzEdt\TikzEdt\0.2.3.0 open the file temp_header.tex and make sure it maches the Pre-amble in TikzEdt. The directory and the file are both hidden, so you have to check that hidden files are displayed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.