TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm editing a thesis using XeLaTeX. In some pages there are at least two footnotes and sometimes one of them ends with a filled line (I'm not sure this is the best name), so there is an empty line before the next footnote, as shown in the figure empty line between footnotes.

The author of the thesis doesn't like that empty line; is there any way of avoiding those lines?

Edit: a MWE which shows the same problem, but also that the blank line does not always shows up.



This is a sentence.\footnote{ \lipsum[1] } This is another sentence.\footnote{ \lipsum[2] }

This is another paragraph.\footnote{\lipsum*[3]} This is yet another sentence.\footnote{ \lipsum[4] }


In the thesis I could get rid of the blank lines by removing a trailing space in the first footnote, as suggested by @David Carlisle. Why isn't there an empty line between footnotes 1 and 2 of the MWE?

share|improve this question
Welcome to TeX.SX! I would guess that there's some additional blank somewhere that causes a line break then. Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Benedikt Bauer Oct 15 '13 at 13:04
Most likely (you should always show your input document) the line is not empty but contains a space. Don't do word\footnote{aaa} \footnote{bbb} with a space (or newline) between the footnotes. do word\footnote{aaa}\footnote{bbb} – David Carlisle Oct 15 '13 at 13:05
There is no space because you are using the nopar option of lipsum. This is what you want, normally: no blank space between footnotes. If you do need/want it, you can modify the footnote-related command(s) in various ways. Note: using \footnote{ \lipsum[1] } gives two spurious spaces in your output; don't do it: write instead \footnote{\lipsum[1]}. Whitespace is important in (La)TeX and rarely ignored. – jon Oct 15 '13 at 14:26
If you have a blank line with you real footnotes, please try and make a minimal example without lipsum. – egreg Oct 16 '13 at 6:29

If you change \lipsum*[3] to \lipsum[3] including \usepackage[nopar]{lipsum}, then the footnotes won't have any space between one another.

If you remove [nopar] they will gain a little space between them.

share|improve this answer
Yes, that's the difference between the first and the second paragraphs. My question is why sometimes a trailing space in a footnote (as in my original document) introduce an empty line between footnotes, and sometimes not (as in the first paragraph of the MWE). – Miguel Pagano Oct 15 '13 at 14:23
@MiguelPagano Trailing space? Sorry, I don't understand what you are referring to (my bad :P). The only thing that counts is that asterisk and the [nopar] option. I tried spacing randomly the footnotes commands but nothing changes. – Alenanno Oct 15 '13 at 14:33
\lipsum[3] executes \par at the end; the normal behavior of \footnote is to add a strut after the footnote text and the trailing \par will make the strut start a new paragraph that will appear as an empty line. With \lipsum*[3] the trailing \par is not inserted. – egreg Oct 15 '13 at 15:24
I think I have the same problem as @egreg described. Can be the case that the strut also starts a new paragraph if there is a space after the period finishing the footnote? I have to learn what is a strut: any reference? egreg if you post your comment as an answer I will accept it. Alenanno thanks also for your answer. – Miguel Pagano Oct 15 '13 at 23:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.