TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is my first post on here and I'm a fairly novice user of LaTeX so forgive my lack of knowledge.

I'm trying to use a Cambridge Uni thesis LaTeX template and adapting it to use Biblatex, but after 2 days of struggling and searching existing information, I seem to have reached a bit of an impasse. I've (finally) managed to get it to run without spitting errors out, but the style of the citations is completely messed up.

Basically I'm just after a simple clean author-year style in the text, such as "(Authors, Year)", with the bibliography appearing as "Authors, Year. Title. Location:Publisher.".

The bibliography is appearing as desired, but the in-text citation is bizarrely coming out with the full title of the reference, but no author and no year, even though the option style=authoryear is activated for biblatex in the preamble.

The .tex file looks like this

%input macros (i.e. write your own macros file called MacroFile1.tex)


  bibliography = {References},% replace "references" with "bibliography"  for `book`/`report`

    \pdfinfo { /Title  (CUED PhD and MPhil Thesis Classes)
               /Creator (TeX)
               /Producer (pdfTeX)
               /Author (Harish Bhanderi harish.bhanderi@cantab.net)
               /CreationDate (D:20030101000000)  %format D:YYYYMMDDhhmmss
               /ModDate (D:20030815213532)
               /Subject (Writing a PhD thesis in LaTeX)
               /Keywords (PhD, Thesis)}
    \pdfcatalog { /PageMode (/UseOutlines)
                  /OpenAction (fitbh)  }

% Set URL hyperlinks to black
\hypersetup{urlcolor = black}

\title{Writing a PhD Thesis\\[1ex]
        in \LaTeXe}

  \author{\href{mailto:harish.bhanderi@cantab.net}{Harish Bhanderi}}
  \collegeordept{\href{http://www.eng.cam.ac.uk}{Department of Engineering}}
  \university{\href{http://www.cam.ac.uk}{University of Cambridge}}
% insert below the file name that contains the crest in-place of 'UnivShield'
  \author{Harish Bhanderi}
  \collegeordept{Department of Engineering}
  \university{University of Cambridge}
% insert below the file name that contains the crest in-place of 'UnivShield'
  \crest{\includegraphics[bb = 0 0 292 336, width=30mm]{UnivShield}}

%\renewcommand{\submittedtext}{change the default text here if needed}
\degreetype{Type of degree}
\degree{Degree Title}
\degreedate{Date submitted\vspace{-3ex}}

% turn off those nasty overfull and underfull hboxes

% Put all the style files you want in the directory StyleFiles and usepackage like this:

% Comment out the next line to get single spacing

% Reset URL hyperlinks to blue
\hypersetup{urlcolor = blue}



% A page with the abstract on including title and author etc may be
% required to be handed in separately. If this is not so, then comment
% the below 3 lines (between '\begin{abstractseparte}' and 
% 'end{abstractseparate}'), normally like a declaration ... needs some more
% work, mind as environment abstracts creates a new page!
% \begin{abstractseparate}
%   \input{Abstract/abstract}
% \end{abstractseparate}

  {\parindent \z@ \raggedright \normalfont
    \ifnum \c@secnumdepth >\m@ne
        %\huge\bfseries \@chapapp\space \thechapter
        \Huge\bfseries \thechapter.\space%
        %\vskip 20\p@
    \Huge \bfseries #1\par\nobreak
    \vskip 40\p@

% Using the watermark package which is in StyleFiles/
% and to remove DRAFT COPY ONLY appearing on the top of all pages comment out below line
\watermark{DRAFT COPY ONLY}


%set the number of sectioning levels that get numbered and appear in the contents

\frontmatter % book mode only

\printnomenclature  %% Print the nomenclature

\mainmatter % book mode only

%\bibliographystyle{Classes/jmb} % bibliography style
%\renewcommand{\bibname}{References} % changes default name Bibliography to References
%\bibliography{References/references} % References file

\backmatter % book mode only


The modified class file being called looks like this:

% CUEDthesis v1.1
% By Harish Bhanderi <harish.bhanderi@cantab.net
% Version 1.0 released 15/07/2002
% Version 1.1 released 14/07/2010
%-------------------------- identification ---------------------
\ProvidesClass{salfordthesis}[2010/07/14 v1.1 CUED thesis class]
%-------------------------- initial code -----------------------


   \LoadClass[dvips, a4paper]{book}%
   \LoadClass[pdftex, a4paper]{book}%
  \LoadClass[dvips, a4paper]{report}%
   \LoadClass[pdftex, a4paper]{report}%

\usepackage{amsmath, amsthm, amssymb}
\usepackage[usenames, dvipsnames]{color}

%uncomment next line to change bibliography name to references for Book document class
% note that this doesn't do much if you later define another bibliography style 

% Nomenclature
   \item[\textbf{Roman Symbols}] }{%             A - Roman
     \item[\textbf{Greek Symbols}]}{%             G - Greek
        \item[\textbf{Superscripts}]}{%              R - Superscripts
           \item[\textbf{Subscripts}]}{{%             S - Subscripts
         \item[\textbf{Other Symbols}]}{{%    X - Other Symbols
         \item[\textbf{Acronyms}]}%              Z - Acronyms

%--> Google.com search "hyperref options"
%--> http://www.ai.mit.edu/lab/sysadmin/latex/documentation/latex/hyperref/manual.pdf
%--> http://www.chemie.unibas.ch/~vogtp/LaTeX2PDFLaTeX.pdf 
%--> http://www.uni-giessen.de/partosch/eurotex99/ oberdiek/print/sli4a4col.pdf
%--> http://me.in-berlin.de/~miwie/tex-refs/html/latex-packages.html
    \usepackage[ pdftex, plainpages = false, pdfpagelabels, 
                 pdfpagelayout = OneColumn, % display single page, advancing flips the page - Sasa Tomic
                 bookmarksopen = true,
                 bookmarksnumbered = true,
                 breaklinks = true,
                 colorlinks = true,
                 linkcolor = blue,
                 urlcolor  = blue,
                 citecolor = red,
                 anchorcolor = green,
                 hyperindex = true,
    \DeclareGraphicsExtensions{.png, .jpg, .pdf}

    \usepackage[ dvips, 
                 bookmarksopen = true,
                 bookmarksnumbered = true,
                 breaklinks = true,
                 colorlinks = true,
                 linkcolor = blue,
                 urlcolor  = blue,
                 citecolor = red,
                 anchorcolor = green,
                 hyperindex = true,

    \DeclareGraphicsExtensions{.eps, .ps}

%define the page size including an offset for binding

%A4 settings



\renewcommand{\chaptermark}[1]{\markboth{\MakeUppercase{\thechapter. #1 }}{}}

\newcommand{\submittedtext}{{A thesis submitted for the degree of}}
% These macros are used to declare arguments needed for the
% construction of the title page and other preamble.

% The year and term the degree will be officially conferred
% The type of degree
% The full (unabbreviated) name of the degree
% The name of your college or department(eg. Trinity, Pembroke, Maths, Physics)
% The name of your school
% The name of your University
% Defining the crest

% These macros define an environment for front matter that is always 
% single column even in a double-column document.


%define title page layout
\pagenumbering{roman} % Sasa Tomic
\setcounter{page}{0}  % Sasa Tomic
%  \null\vfill
    { \Huge {\bfseries {\@title}} \par}
{\large \vspace*{35mm} {{\@crest} \par} \vspace*{25mm}}
    {{\Large \@author} \par}
{\large \vspace*{1ex}
    {{\@collegeordept} \par}
    {{\@school} \par}
    {{\@university} \par}
    {{\submittedtext} \par}
    {\it {\@degreetype} \par}
    {\it {\@degree} \par}

% The dedication environment makes sure the dedication gets its
% own page and is set out in verse format.

  {\LARGE }
  \begin{quote} \begin{center}}
{\end{center} \end{quote} \end{alwayssingle}}

% The acknowledgements environment puts a large, bold, centered 
% "Acknowledgements" label at the top of the page. The acknowledgements
% themselves appear in a quote environment, i.e. tabbed in at both sides, and
% on its own page.

{\Large \bfseries Acknowledgements}

% The acknowledgementslong environment puts a large, bold, centered 
% "Acknowledgements" label at the top of the page. The acknowledgement itself 
% does not appears in a quote environment so you can get more in.

{\Large \bfseries Acknowledgements}

%The abstract environment puts a large, bold, centered "Abstract" label at
%the top of the page. The abstract itself appears in a quote environment,
%i.e. tabbed in at both sides, and on its own page.

\newenvironment{abstracts} {\begin{alwayssingle} \pagestyle{empty}
  {\Large \bfseries  Abstract}

%The abstractlong environment puts a large, bold, centered "Abstract" label at
%the top of the page. The abstract itself does not appears in a quote
%environment so you can get more in.

\newenvironment{abstractslong} {\begin{alwayssingle} \pagestyle{empty}
  {\Large \bfseries  Abstract}
  \vspace{0.5cm} \begin{quote}}

%The abstractseparate environment is for running of a page with the abstract
%on including title and author etc as required to be handed in separately

\newenvironment{abstractseparate} {\begin{alwayssingle} \pagestyle{empty}
    { \Large {\bfseries {\@title}} \par}
    {{\large \vspace*{1ex} \@author} \par}
{\large \vspace*{1ex}
    {{\@collegeordept} \par}
    {{\@school} \par}
    {{\@university} \par}
    {{\it \submittedtext} \par}
    {\it {\@degreetype} \par}
    {\it {\@degree} \par}

% The romanpages environment set the page numbering to lowercase roman one
% for the contents and figures lists. It also resets
% page-numbering for the remainder of the dissertation (arabic, starting at 1).


I've also tried to use the biblatex-apa style, but Texmaker refuses to compile declaring "! Undefined control sequence. \DeclareLabeldate" and "! Undefined control sequence. \field" and "! Undefined control sequence. \literal". I have attempted to fix this using file modifications found via http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709790 but to no avail.

The references.bib file just contains a couple of sample references, inserted using Texmaker's biblatex bibliography entry insertion tool. The text citations in the chapters are just using \cite{reference}, since it seems I can no longer use \citep or \citet with biblatex.

Questions: 1. Could someone point out where the problem with the biblatex in-text citations is? 2. Do I need to write some sort of special .bst file for this?

I'm just about reaching my wit's end with biblatex, it seems so impossibly convoluted that things that should be simple take days of research!

Any assistance would be greatly appreciated

Update: I've come across this discussion on TeX.se: Unexpected citation behavior: biblatex with biber and authoryear

This may be the same problem, but I don't know how to implement a solution in Texmaker - can anyone suggest something?

Update: After updating via the MikTex package manager, Texmaker is refusing to compile the file at all. During the update I noticed that the package manager had identified biblatex as a package that was obselete and would be removed, which I allowed since I assumed it would know what it was doing. Since the update the file won't compile at all, and I get multiple errors, as shown in the picture:

Texmaker errors

If I go the MikTeX package manager now however, biblatex is still listed as installed.

I'm at a complete loss.

share|improve this question

closed as off-topic by Guido, lockstep, egreg, Andrew Swann, moewe Oct 17 '13 at 21:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Guido, lockstep
If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to TeX.SX! How are you citing? In text citations are supposed to be made via \textcite. There's also an \autocite command, which in authoryear style is of the “(Author, Year)” form. Take a look at the examples from the biblatex documentation. – henrique Oct 16 '13 at 12:38
Hi Henrique, thanks for your response. I've tried using \cite, \textcite and \parencite, and have also tried specifying the bibstyle=authoryear and citestyle=authoryear separately, but the in-text reference is still coming out with the reference title! I've had a look at the authoryear example at the CTAN base, but worryingly can't get it to compile on Texmaker, which spits out: – Mike Oct 16 '13 at 13:16
Process started Can't use string ("matuz:doody") as an ARRAY ref while "strict refs" in use at C:\Users\Mike\AppData\Local\Temp\par-4d696b65\cache-c3e641bac9e7e4b5ab17068122bf‌​f38686710985\inc\lib/Biber/Entry.pm line 74. INFO - This is Biber 1.7 INFO - Logfile is 'authoryearex.blg' INFO - Reading 'authoryearex.bcf' WARN - Warning: Found biblatex control file version 2.3, expected version 2.5 INFO - Using all citekeys in bib section 0 INFO - Processing section 0 INFO - Looking for bibtex format file 'biblatex-examples.bib' for section 0 INFO - Found BibTeX data source 'biblatex-examples.bib' – Mike Oct 16 '13 at 13:16
Process exited with error(s) – Mike Oct 16 '13 at 13:17
This question appears to be off-topic because it is about a problem due to improper installation of software – egreg Oct 16 '13 at 22:30
up vote 0 down vote accepted

Reinstalling biblatex has solved the issue, as well as resolving multiple errors following a MikTeX update, as discussed at MikTeX update has killed LaTeX.

Thanks for the help received.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.