Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently updated my Operating system from Ubuntu 13.04 to Ubuntu 13.10.

Since then, I am facing difficulties compiling my tex code in which the french babel package is called. Please note that all my codes were working very fine before the system upgrade.

However, now, given the following header :

  \usepackage[francais]{babel}

I receive the following error :

! Package babel Error: Unknown option `francais'. Either you misspelled it

What should I do ? Please note that if I remove this part of code (\usepackage[francais]{babel}), everything is compiling good. I also tried it with french, and I receive the same result.

Thank you in advance for your help.


MINIMUM WORKING EXAMPLE :

\documentclass[11pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[francais]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}

\begin{document}
This is a MINIMUM WORKING EXAMPLE.
\end{document}
! Package babel Error: Unknow option `francais'. Either you misspelled it
share|improve this question
    
It's french not francais –  YuppieNetworking Oct 20 '13 at 13:39
3  
@YuppieNetworking : Unfortunately, it's not working either with french. I receive the same error. –  Martingal Oct 20 '13 at 13:41
    
Then you should edit your question to specify that it is not working with the french option, and add all your preamble for us to see if there is some problems in it. –  Ludovic C. Oct 20 '13 at 13:44
4  
@LudovicC. It worked with francais before the upgrade. And only this line gives this error. If I remove it, there is no further error. –  Martingal Oct 20 '13 at 13:49
7  
@Alenanno : Yes, I need that package, otherwise I wouldn't be asking here ... Especially when it's french reports. –  Martingal Oct 20 '13 at 13:54

3 Answers 3

up vote 33 down vote accepted

The complete error message is:

! Package babel Error: Unknown option `francais'. Either you misspelled it
(babel)                or the language definition file francais.ldf was not found.

Package file babel.sty supports francais since a very long time, thus the second line of the error message applies very likely:

The organization of the babel language files has recently changed. The language files (.ldf, ...) go into separate TeX distribution packages. For example, option francais loads frenchb.ldf:

  • TeX Live puts the latter in the distribution package babel-french. It needs to be installed, if you are using tlmgr, the package manager of TeX Live.

  • In Ubuntu saucy there is a package texlive-lang-french that contains frenchb.ldf (file list). Install it, if you are using TeX Live of Ubuntu.

share|improve this answer
1  
Your second proposal solved my problem. Thank you very much for your help. I have no idea why it was removed when upgrading the system. Anyway, thanks again ! –  Martingal Oct 20 '13 at 14:16
    
FWIW: In Fedora 18+, packages like texlive-babel-german contains the relevant files. –  Frederick Nord Jan 7 at 15:16

Exactly same issue here for various languages like: \usepackage[dutch]{babel}

A way of solving: Open: Ubuntu Software Center and install: texlive-lang-all

But what still changed is that in case you change the language in the \usepackage[english]{babel} you have to remove the temporary latex files before latex-ing again. But with that remark every works again as before.

share|improve this answer

I had the same error while trying to generate the pdf files from lyx. I did run sudo apt-get texlive-lang-french and the error was resolved. Now working fine

Update: These packages have become obsolete; texlive-lang-european should be installed now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.