Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm not sure if this is the right place to ask this question, so if not, please let me know where it would be more appropriate.

Since upgrading to Ubuntu 13.10, something seems to have gone wonky with RefTeX. It seems that Emacs was "upgraded" to 24.3.1, and I think this may be the culprit.

The problem: when I type C-c ) to insert a label, instead of just going to my list of references as usual, the frame splits in half and the following appears in the bottom half:

SELECT A REFERENCE FORMAT

[^M] \ref

[p] \pageref

If I hit C-m then it goes to my reference list and I can choose the reference as I normally would. I really don't want to have this extra step there, any idea how to disable that and restore the previous behavior?

In case it matters, I'm also using the solution from this answer to make RefTeX work with cleverref.

share|improve this question

1 Answer 1

up vote 8 down vote accepted

To skip the selection of the reference style you have to set the variable reftex-ref-macro-prompt to nil, see the RefTeX manual. To do this you can customize that variable or add the following code to your init file:

(setq reftex-ref-macro-prompt nil)

It has been reported that this solution to use RefTeX with the cleverref package no longer works with Emacs 24.3.1 and AUCTeX 11.87, look at this instead.

share|improve this answer
    
Thank you! You were of course correct, that solution that I referenced no longer works, but the newer one that you link to does. –  MTS Oct 21 '13 at 18:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.