Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use bibtool to extract bibliography information from an aux file. I'm using this MWE:

\documentclass[12pt]{article}
\usepackage{filecontents}
\begin{filecontents}{foo.bib}
@Book{dickens,
    author={Charles Dickens},
    title={A Tale of Two Cities},
    year=1859,
    publisher={Chapman and Hall}
  }
\end{filecontents}
\usepackage[style=verbose]{biblatex}
\bibliography{foo}

\begin{document}
\cite{dickens}

\end{document}

When I run:

bibtool -x test.aux -o refs.bib

I get the following errors:

*** BibTool WARNING:  (line 2 in ./test-blx.bib): 23 non-space characters ignored.

*** BibTool WARNING:  (line 9 in ./test-blx.bib): 168 non-space characters ignored.

@Control{biblatex-control,
_^
*** BibTool ERROR:  (line 9 in ./test-blx.bib): Unknown entry type

*** BibTool WARNING: Skiping to next '@'

*** BibTool WARNING:  (line 5 in ./foo.bib): 96 non-space characters ignored.

My test.aux is as follows:

\relax 
\bibstyle{biblatex}
\bibdata{test-blx,foo}
\citation{biblatex-control}
\citation{dickens}
\@writefile{toc}{\boolfalse {citerequest}\boolfalse {citetracker}\boolfalse {pagetracker}\boolfalse {backtracker}\relax }
\@writefile{lof}{\boolfalse {citerequest}\boolfalse {citetracker}\boolfalse {pagetracker}\boolfalse {backtracker}\relax }
\@writefile{lot}{\boolfalse {citerequest}\boolfalse {citetracker}\boolfalse {pagetracker}\boolfalse {backtracker}\relax }
\abx@aux@page{1}{1}

I presume this problem is because this tool has been written for bibtex rather than biblatex. Is there a way to use this tool to extract the information, or is there a way to extract the bibliography information I need?

share|improve this question
2  
In case you are using biber to generate the bibliography, you might want to checkout the --output-format=bibtex commandline option as described in its manual. –  michel Nov 14 '13 at 19:51

1 Answer 1

up vote 6 down vote accepted

I found an answer to this. Change \bibstyle to plain in your .aux file, and delete the \citation{biblatex-control} line. bibtool should now be able to read your bibliography as per usual. (You might also want to remove test-blx.bib from the \bibdata thing, I can't remember if it works without that)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.