Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Yesterday I installed TeXstudio on my Ubuntu system. I realized it has nice functions like "jump to PDF" (goes to PDF and highlights the marked text) and "go to source code" (goes to the source code of that part that was clicked in the PDF):

Now I installed TeXstudio under Mac OS X, and those functions do not work. Strangely it was also configured in a way that external viewers were used to show the PDF. I changed everything to "internal PDF viewer", but still these nice "jump function" don't work.

What do I have to change (in the preferences), so that I use those function? Or is it not possible to use them within Mac OS X?

share|improve this question
    
Have you the synctex command included in your path? For me with "/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex the jump-function works fine –  samcarter Oct 23 '13 at 8:33
    
-synctex=1 was there for xelatex and lualatex, but not for latex and pdflatex. I added it, and now it works. Please write an answer, so that I can accept it,... –  Sven Oct 23 '13 at 9:11
1  
synctex sometimes has (or had, not sure if this is solved completely) problems if there is whitespace in the path or filename of your tex document. –  Tim Hoffmann Oct 23 '13 at 21:37

1 Answer 1

up vote 5 down vote accepted

[turning previous comment into answer]

Add -synctex=1 to your path, e.g.

"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex

Then the jump-function should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.