Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was trying biblatex/biber in TexWorks. The LaTeX and bib file works when I use biblatex but failed to compile when I use biber.

Here are my LaTeX file and the bib file. The last entry in the bib file is my entry copied from my bib file. Other entries are from the working example file.


\documentclass[]{article}

\usepackage[autostyle]{csquotes}

\usepackage[
    backend=biber,
    style=authoryear-icomp,
    sortlocale=de_DE,
    natbib=true,
    url=false, 
    doi=true,
    eprint=false
]{biblatex}
\addbibresource{C:/Users/guest/Desktop/testing_biblatex/biblatex-examples_local.bib}

\usepackage[]{hyperref}
\hypersetup{
    colorlinks=true,
}

%% ##############################
\begin{document}
    At vero eos et accusam et justo duo dolores et ea rebum~\citet{geer}.   
    Lorem ipsum dolor sit amet~\autocite{loh}.
    This is the problematic entry \citep{Albert2007}.
    \printbibliography 
\end{document}



@Thesis{geer,
  author       = {de Geer, Ingrid},
  title        = {Earl, Saint, Bishop, Skald~-- and Music},
  type         = {phdthesis},
  institution  = {Uppsala Universitet},
  date         = 1985,
  subtitle     = {The Orkney Earldom of the Twelfth Century. A Musicological
                  Study},
  location     = {Uppsala},
  options      = {useprefix=false},
  hyphenation  = {british},
  annotation   = {This is a typical \texttt{thesis} entry for a PhD thesis. Note
                  the \texttt{type} field in the database file which uses a
                  localization key. Also note the format of the printed name and
                  compare the \texttt{useprefix} option in the \texttt{options}
                  field as well as \texttt{vangennep}},
}

@Thesis{loh,
  author       = {Loh, Nin C.},
  title        = {High-Resolution Micromachined Interferometric Accelerometer},
  type         = {mathesis},
  institution  = {Massachusetts Institute of Technology},
  date         = 1992,
  location     = {Cambridge, Mass.},
  hyphenation  = {american},
  annotation   = {This is a typical \texttt{thesis} entry for an MA thesis. Note
                  the \texttt{type} field in the database file which uses a
                  localization key},
}

@Article{Albert2007,
author = {Albert, I and Mavrich, TN and Tomsho, LP and Qi, J and Zanton, SJ and Schuster, S.C. and Pugh, B.F.},
issn = {0028-0836},
journal = {Nature},
keywords = {nucleosome},
mendeley-tags = {nucleosome},
number = {7135},
pages = {572--576},
publisher = {Nature Publishing Group},
title = {{Translational and rotational settings of H2A. Z nucleosomes across the Saccharomyces cerevisiae genome}},
url = {http://www.nature.com/nature/journal/v446/n7135/abs/nature05632.html},
volume = {446},
year = {2007}
}
share|improve this question

closed as unclear what you're asking by moewe, Adam Liter, Jubobs, Peter Jansson, Andrew Swann Mar 24 at 16:11

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Your .bib file lacks the closing } for Albert2007. Fixing that, your code works for me. :) –  Paulo Cereda Oct 24 '13 at 14:49
    
Same for me.... –  karlkoeller Oct 24 '13 at 14:50
    
Does it? I'm afraid I missed the closing } while copying to here. My file has the closing }, yet it does not work. :( –  microbe Oct 24 '13 at 15:18
    
I can confirm it works. Did you run Biber? –  egreg Oct 24 '13 at 15:24
    
Yes. If I run it with backend=bibtex, then it works. I noticed some differences in bib fields, such as date vs year. I deleted the fields one by one and if I deleted extra fields and changed the remaining names to the same as the examples, then it works. I'm using MikTeK 2.9 and biber installed through the package management tool. Maybe the version problem? –  microbe Oct 24 '13 at 15:41

1 Answer 1

if you export bibtex with mendeley, you should also empty Mendeley's trash before the export. otherwise you may have duplicate bibtex entries in your bibtex file (which may cause problems).

btw. if you are looking for an alternative, or enhancement, to Mendeley, you may be interested in Docear, a software I am developing: http://www.docear.org/2013/10/17/docear-1-0-stable-a-new-video-new-manual-new-homepage-new-details-page/

share|improve this answer
    
Thank you for the suggestion. In my case, however, duplicate entries were not the problem because even a single entry can cause a problem as in my example. –  microbe Oct 25 '13 at 19:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.