Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

After upgrading the ubuntu 13.04 to 13.10, when I try the following command in terminal

$ latex *.tex or $ pdflatex *.tex .

I give the following error with MWE:

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
 restricted \write18 enabled.
---! /var/lib/texmf/web2c/pdftex/pdflatex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

Also Texmaker gives error "Could not start the command".

Meanwhile, my Texmaker configuration is as follows:

enter image description here

Any suggestion?

share|improve this question
1  
I think you may have to rebuilt the format with something like: sudo fmtutil-sys --all. I vaguely remember needing to do that once after an update. –  jon Oct 24 '13 at 20:35
    
Thank you @jon for reply, but nothing change. –  ferahfeza Oct 24 '13 at 20:45
1  
Well, it's not TeXmaker, so don't worry about that. You need to sort out things at a deeper level. Your last comment means that something like latex small2e still gives you the same exact error you first described, right? Did you rebuild the formats with fmtutil-sys and did it run without any errors? –  jon Oct 24 '13 at 20:51
2  
My advice would be to uninstall all system-installed TeX Live with sudo apt-get purge texlive* and sudo apt-get autoclean. Then reinstalling TeX Live, but from here. And definitely don't go back to Windows! :) –  jon Oct 24 '13 at 21:37
2  
You might be interested in install-tl-ubuntu which does everything for you to install TeX Live 2013 and notify apt so apt does not try to install the texlive packages as dependencies. –  scottkosty Oct 24 '13 at 23:40

2 Answers 2

I got the same error with Pandoc. It was:

pandoc: Error producing PDF from TeX source.             
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
 restricted \write18 enabled.
---! /home/user/.texmf-var/web2c/pdftex/pdflatex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

I fixed it by removing / renaming the /home/user/.texmf-var folder.

It happened probably because of my system upgrade. That folder probably contains older cache files that are incompatible with the newer latex version that I now have installed.

In your case, the problem is with a system folder.

I recommend trying to find the command that rebuilds these caches (like some suggested in the comments), or, alternatively, uninstalling latex and re-installing it again - probably that will generate them anew.

share|improve this answer

I could solve this problem with

sudo dpkg --configure -a

I hope this help you.

(I sorry for my english).

share|improve this answer
    
Thank you. I solved my problem. –  ferahfeza May 21 at 7:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.