Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using IEEEtran.cls for a journal paper and I'm unable to make a one column abstract using the inbuilt commands in IEEEtran: \onecolumn, \twocolumn. Switching between the two flushes the page and starts a new one. \nopagebreak doesn't work. Tried putting samepage tags. Didn't help either. I'm compiling using Xelatex. Any way to make one column and two column in the same page?

share|improve this question
1  
do you want the one column to insert a Figure or Table? –  Mario S. E. Oct 25 '13 at 9:42
    
@MarioS.E. I need for a onecolumn abstract. –  SPRajagopal Oct 25 '13 at 9:47
3  
because IEEE doesn't use one column abstract. why do you want to modify it if it is going to be an IEEE paper? –  percusse Oct 25 '13 at 9:48
    
I'm with @percusse on this one. IEEE only uses one column for large tables or figures, and for that you just need \begin{figure*}...\end{figure*} or \begin{table*}...\end{table*} –  Mario S. E. Oct 25 '13 at 9:50
1  
@MarioS.E. I did some naughty stuff before :) but I really recommend not doing this the fonts and other settings look ugly. Evidence : tex.stackexchange.com/a/50715/3235 –  percusse Oct 25 '13 at 9:59

1 Answer 1

A minimal working example:

MWE

\documentclass{IEEEtran}
\usepackage{microtype}
\usepackage{lipsum}
\title{The title}
\author{You}
\begin{document}
\twocolumn[
\begin{@twocolumnfalse}
\maketitle
\end{@twocolumnfalse}
\begin{abstract}
~{\lipsum[1]\lipsum[1]}
\end{abstract}
\bigskip]
\section{Introduction}
\lipsum[1-7]
\end{document}

Note: For some reason \lipsum[1] inside the abstract environment must be enclosed with brackets and must be at least one character before (it can be be ~, but no a normal space), but nothing of this is needed for real text.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.