Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use biblatex and when I compile my document I get an error like the following:

Windows

data source C:\Users\<username>\AppData\Local\Temp\par-5061756c\
cache-890efc00b3ca6b775c7d44a325c1349fb2a3a3bd\inc\lib/Biber/LaTeX/recode_data.xml not found in .

Mac

data source /var/folders/v2/rld0ls7d2935gkvqv5hfr1x00000gn/T/par-616c616e/
cache-cdd483146f82a9655ce063f848d5139480fbf872/inc/lib/Biber/LaTeX/recode_data.xml not found in .

Linux

data source /tmp/par-6963617269756d/cache-f37ab610b7d79b2720a8ee3732849c6821705520
/inc/lib/Biber/LaTeX/recode_data.xml not found in .
share|improve this question
    
tex.stackexchange.com/a/18868/1998 –  pmav99 Oct 26 '13 at 18:49
    
@pmav99 I'm making this a canonical question/answer that we can link to as a duplicate. –  Alan Munn Oct 26 '13 at 18:51
1  
Ok, I just added the comment so that the questions appear linked. –  pmav99 Oct 26 '13 at 18:53
    
@Joseph Wright: You mean to mark the older question as duplicate of this one? Yeah, why not? This is the correct answer to a whole series of biber related problems. –  pmav99 Oct 26 '13 at 20:48

1 Answer 1

up vote 58 down vote accepted

The error you are getting is a well known issue with biber. It creates binaries in a cache folder, and sometimes that can get corrupted. In order to solve the problem, you need to manually delete the cache folders. The name of the cache folder will be something like the following:

  • par-<hex_encoded_username>/cache-*
  • par-<hex_encoded_username>\cache-*

for Linux/OS and Windows respectively. They are located in different places on different platforms:

  • /var/folders/*/*/*/ (OSX, local GUI login shell)
  • /var/tmp/ (OSX (remote ssh login shell), Unix)
  • /tmp/ (Linux)
  • C:\Documents and Settings\<username>\Local Settings\Temp (Windows XP/Cyg- win)
  • C:\Windows\Temp (Windows)
  • C:\Users\<username>\AppData\Local\Temp (Windows 7/8)

You need to delete the relevant cache folders and compile your document again. You can find the location of the cache folder by looking at the .blg file, or by using the command.

biber --cache

On Linux and Mac, this can be combined to delete the offending folder in one command:

rm -rf `biber --cache`

More information can be found on section 4.1 of the biber manual (Section 4.1 Binary Caches - Biber Version 1.7).

share|improve this answer
    
You may add that the information about the location of the faulty cache can also be found in the .blg file. –  egreg Oct 26 '13 at 22:13
1  
And it can be found by simply looking at the error message: `C:\Users\<username>\AppData\Local\Temp\par-5061756c` –  Ulrike Fischer Oct 27 '13 at 10:28
2  
I solve this problem in *NIX systems (linux and MacOX) on the command line with rm -Rf "biber --cache" (sorry, I do not know how to markdown backquotes, so I used " insted). Maybe you want to incorporate this into your answer. –  Michael Kohlhase Feb 14 at 6:17
    
This is great. Does anybody now if this has been reported to the package maintainers? I know I've been getting this bug for well over a year and I'm still getting this on biber v. 1.8. –  shane Mar 12 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.