Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

When I run my LaTeX document through pdflatex, some of the pages (the ones where figures appear) have all the text bolded. Why, and what can I do to make it stop?

share|improve this question

marked as duplicate by Martin Schröder, Heiko Oberdiek, Claudio Fiandrino, Red, Guido Sep 23 '13 at 8:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
never mind, the solution only seems to work for TikZ pictures, not for transparent pngs. –  Caramdir Jan 20 '11 at 21:05
    
I have a similar problem with pdf files from pdflatex, although the text appears normal on the screen it prints out as bold in pages where there are images (this only happens in colour printers). No transparency is used in the figures and it happens with all formats (pdf, png, and jpg). Any suggestions are welcome! –  user11256 Jan 29 '12 at 11:35
2  
Did you read the FAQ? It is impossible for us to see what your source looks like. There may be several reasons for your problem, which is why everybody is guessing as to what's causing it. Please provide a minimal example. –  Marc van Dongen Jan 29 '12 at 11:52
    
@GeorgeK. I converted your post, which you accidentally posted as answer below, into a comment to the question, because the space below is reserved for actual answers. –  Stefan Kottwitz Jan 29 '12 at 12:23
    
This may not be considered as a real answer by many, but I simply use Google Chrome to open pdf docuemtns. It's cluster free, not memory intensive, and extremely fast. It also doesn't have any anti-aliasing or gamma correction issues. –  cartonn Jan 10 '13 at 21:12

7 Answers 7

up vote 35 down vote accepted

I guess you are using Adobe Reader? If you use transparency in your illustrations, it seems that Adobe Reader renders text incorrectly (something like the wrong gamma correction in anti-aliasing perhaps), which makes the text look a bit too bold. It should look OK if you use other PDF readers, and it should also look OK when printed from Adobe Reader.

A simple solution is to avoid using transparency whenever possible.

You can remove transparency from existing PNG images using graphics editors like GIMP or Photoshop, or with a command-line program like ImageMagick. With ImageMagick, the command convert image.png -background white -alpha off image_new.png will remove the transparency (from http://www.imagemagick.org/Usage/masking/#alpha_remove).

share|improve this answer
1  
I checked this transparency issue and on Windows Acrobat Reader 9.3.3 works correctly. On Linux acroread 9.3.2 works incorrectly with the same file with transparency. –  Łukasz Lew Aug 18 '10 at 14:21
10  
Another simple solution is to avoid Adobe Reader whenever possible. –  Marco Nov 14 '11 at 18:37
1  
@Jukka: Would you mind if I added an explanation for removing the transparency from existing images using ImageMagick? –  Jake Mar 24 '12 at 6:18
1  
@Jake: Sounds like a good idea, feel free to edit the post. –  Jukka Suomela Mar 24 '12 at 8:57
2  
@Marco : most of the time people write texts for others to read. Choosing ones softwares is one thing; choosing what others should use is really something else. –  Alfred M. Jan 31 '13 at 14:29

Download the latest version of adobe reader 11 . it's working now

http://get.adobe.com/reader/

or see any other pdf readers

share|improve this answer
1  
Welcome to TeX.SX! –  Papiro Aug 17 '13 at 11:54

I had such an issue when mixing pages with images with and without transparency. If you experience this in Acrobat Reader (almost all including recent versions), but not other PDF readers, the following code in the preamble might do the trick and enforce the same RGB rendering for all pages (for xelatex):

\AddToShipoutPicture{%
\makeatletter%
\special{pdf: put @thispage <</Group << /S /Transparency /I true /CS /DeviceRGB>> >>}%
\makeatother%
}

For pdflatex use:

\pdfpageattr {/Group << /S /Transparency /I true /CS /DeviceRGB>>} 

(Answer reposted from Text appearing bold on some pages with images, as the other thread was marked duplicate, but I think it applies here, too.)

share|improve this answer
    
The code means what ? where i run this code ? –  Ramesh Rajendran Aug 17 '13 at 11:04
    
I put it immediately before the relevant \begin{figure} environment, and it worked great for me. Inside the figure environment didn't seem to help, however. –  Scott Morrison Dec 9 at 23:14

I had this problem today and I was quite desperate.

Only way to fix this is to break your text into separate paragraphs near the areas where this issue happens.

Apparently Photoshop exports some texts twice, so you get the same text on top of itself which makes it look bold in the previews.

Sometimes it helps to just change the tracking if it's a single word. Most often it doesn't.

share|improve this answer

I was also wrestling with the "PDF printing bold" issue, and had some success when I flattened transparency. But even when I followed all of the "rules" (images on layer below text, all transparent effects rasterized), the text in my color proofs was still getting inexplicably bold, or more accurately: the text looked like it was printed twice- registration was a bit off.

I'm using InDesign 5.5 to make a 20+ page newsletter (mixed images & text). Tried all kinds of InDesign settings, all kinds of Acrobat settings, but the one that ended up doing the trick was buried in the printer's properties dialogue: Simulate Overprinting. When I turned that on, my text came out exactly as intended, and there was much rejoicing.

There seems to be an odd interaction between Acrobat's print dialogue and some printer settings. For example, you'll get weirdness if you try to print "booklet" via the printer's applet (mine's a Canon C7065), but if you use Adobe Acrobat's "booklet" feature, all is well. For my newsletter to print correctly, I have to set a number of items in both dialogues, and in my case the overprint setting was a big find.

Hope that helps!

Mike Craghead

share|improve this answer

To prime the answer pump with something else I observed: It appears to be a bug in pdflatex stemming from the handling of images with transparency; converting the PNG images to PDFs seems to fix the problem whenever it crops up.

share|improve this answer
1  
I have PDFs generated by Google Docs Drawings that also cause this problem when I use transparency inside of shapes. If I fill shapes with white color it works. There is SVG data in the PDFs. –  OneWorld Aug 28 '12 at 11:30

This may just be your PDF viewer that acting strangely. Even though PDF files are supposedly seen as you would get them, there are some differences in how it looks on screen and on paper.

Back when I was using Windows with Adobe Reader, sometimes scrolling past a page and then back it again would get rid of this "boldness".

share|improve this answer
    
I saw the problem using Adobe Reader on Ubuntu, in which scrolling past and back again doesn't remove the boldness. –  Blake Stacey Jul 26 '10 at 20:49
    
I have Adobe Acrobat 9.0.0 Pro and Adobe Reader 10.1.1 on my Windows Computer. The later version seems handle my PDF almost correct. While on version 9 the boldness was super obvious, you only can guess on version 10 if there is some thicker boldness. –  OneWorld Aug 28 '12 at 11:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.