Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am currently finishing my CV using the moderncv package. To save space I decided to fit all my interests in a multicol environment with 4 columns nested inside an itemize environment. Unfortunately, I get an additional white line after the multicol package that forces my CV to reach 3 pages.

I am already using the command

\setlength{\multicolsep}{0pt} 

globally and this deleted the vertical white space before the multicol environment, but after I still get an additional white line.

Here's the code I'm using:

\documentclass[11pt, a4paper,sans]{moderncv}

% MODERNCV THEME
\moderncvstyle{classic}
\moderncvcolor{blue}
\renewcommand{\familydefault}{\rmdefault}

% CHARACTER ENCODING
\usepackage[utf8]{inputenc}

% ADJUST THE PAGE MARGINS
\usepackage[scale=0.75]{geometry}

\usepackage{microtype}
\DeclareMicrotypeSet[protrusion]{myset}{
        encoding = T1,
        family = {sf*,rm*},
        font = {T1/tt*/m/n/*,
                    T1/tt*/m/it/*} }
\UseMicrotypeSet[protrusion]{myset}

\moderncvicons{awesome}% New icons fontawesome

\usepackage{textcomp}% Adds star as a birthday symbol

\usepackage{multicol}%Usage: \begin{multicols}{2}
\setlength{\multicolsep}{0pt}%Takes space before and after the multicolumn

\newcommand{\localtextbulletone}{\textcolor{color1}{$\vcenter{\hbox{\tiny$\bullet$}}$}}%Changes Item List bullet size and color
\renewcommand{\labelitemi}{\localtextbulletone}%Sets the new bullet type

\begin{document}

\section{Languages}

\cvitemwithcomment{Italian}{Mothertongue}{}
\cvitemwithcomment{English}{Advanced}{European Level: C1; IELTS: 7.5}
\cvitemwithcomment{Spanish}{Intermediate}{Self Assesment: B1}
\cvitemwithcomment{Portuguese}{Basic}{Self Assesment: A2}

\section{Interests}
\cvitem{}{
\begin{itemize}
\item Item 1 (Long item, Long item)\vspace{0.67pt}
\begin{multicols}{4}
    \item Item 2
    \item Item 3
    \item Item 4
    \item Item 5
    \item Item 6
    \item Item 7
    \item Item 8
    \item Item 9
\end{multicols}
\end{itemize}
}

\section{Referees}
\end{document}

and this is the output:enter image description here

As you can see the vertical spacing after the interests section is higher than the spacing in between the languages and interests section. Also,

\usepackage{enumitem}

is not an option since it completely modifies all the spaces.

Is there any way I can delete this additional vertical space?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

A quick fix is to add some negative vertical space, i.e.

\vspace{-\baselineskip}

immediately after \end{multicols}.

share|improve this answer
    
Awesome! It works..! Thanks.. –  DoubleD Oct 30 '13 at 1:03
add comment

You can enclose your itemize environment inside a minipage:

\cvitem{}{%
\begin{minipage}[t]{\linewidth}
\begin{itemize}
\item Item 1 (Long item, Long item)\vspace{0.67pt}
\begin{multicols}{4}
    \item Item 2
    \item Item 3
    \item Item 4
    \item Item 5
    \item Item 6
    \item Item 7
    \item Item 8
    \item Item 9
\end{multicols}
\end{itemize}
\end{minipage}
}

enter image description here

share|improve this answer
    
It works thanks..! –  DoubleD Oct 30 '13 at 1:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.