Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I downloaded the Portuguese dictionary from OpenOffice repository. Following the instructions provided in the TeXnicCenter documentation, I moved the .aff and .dic files to the language folder of the TXC. However, it fails when I try to set it as the default language. Under Options -> Spelling, the option pt-BR is present and I select it as the dicionary to be used and click OK, but I receive the message:

Cannot open: C:\Users\user\Documents\TXCUserDicionary.dic Creating empty personal dictionary.

I am using TeXnicCenter 2.02, 64-bits.

Can anyone guess what's going on here?

share|improve this question
add comment

2 Answers 2

I had the same problem with 'fr' dic. I moved my "personal dictionary" file to a folder where I have the write/read rights (your problem ?), but also under version control (SVN), which allows me to share this file with TEX sources.

Tools\options\Spelling : You can change de 'Personal dictionary' folder

For exemple D:\Applic\LatexDoc\share\TXCUserDictionary.dic

share|improve this answer
add comment

The dictionary  files do not belong into the subfolder Language, but into the subfolder Dictionaries (the help file is wrong here!). The dictionary files are only for spelling corrections, not for the user interface of TeXnicCenter itself. You would need a DLL file (really!) suiting to your favorite language.

Instead of downloading from Apache OpenOffice Dictionaries you could also download from LibreOffice Dictionaries (in both cases do only extract with an archiver, the OXT files are actually zipped). If you already have installed one of these program suites you could also copy the needed files.

I got the error message frequently, too. So I created the empty file myself in this folder I set up in menu “Tools” —> “Options” —> tab “Spelling” —> “Personal”. I do not remember, if I’ve changed here anything or if I left the default setting untouched, because it is here C:\Users\<my-username>\Documents\TXCUserDictionary.dic. When your username is actually user, then I have the default setting, as well.

The program claims, it would create the file itself, but this does not happen. I would consider this a bug. But as far as I see, this was not reported until now in the bug tracker for TXC, see TeXnicCenter / Bugs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.