Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'd like do get the nice oldstyle-numbers in my entire document. (Would there be a reason not to want them anywhere in a literature paper?) I use pdfTeX 1.40.11 via MiKTeX 2.9 and Latin Modern (lmodern) as a font. It seems like I should go for cfr-lm package, or are there alternatives?

What do I have do to to get cfr-lm working? The installation description unfortunately isn't suited for MiKTeX.

My standard documentclass is article. Here are some of the packages I load by default, in case they make any difference:

\usepackage[latin1]{inputenc}
\usepackage[english,ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[babel]{microtype}
share|improve this question
1  
Doesn't MikTeX come with cfr-lm allready installed? At least it should be available through the MikTeX package manager. –  Caramdir Mar 25 '11 at 23:40
    
@Caramdir Usually the package manager works just fine, but if I compile a minimal just containing the above packages and cfr-lm, I get the following error message: !pdfTeX error: C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\pdflatex.exe (file dd-lmr10): Font dd-lmr10 at 600 not found ==> Fatal error occurred, no output PDF file produced! –  doncherry Mar 25 '11 at 23:46
    
Just in case: You shouldn't load lmodern as well as cfr-lm. Also, you do not need to load fontenc if the only encoding you need is T1 (and TS1 for textcomp) though this one won't do any harm. –  cfr Jan 12 at 22:04

1 Answer 1

up vote 4 down vote accepted

Although the cfr-lm package is included in MiKTeX 2.9, the "map" files that include information necessary for TeX to use this font still need to be updated. Do the following:

  • In the command prompt, run initexmf --edit-config-file updmap; this opens updmap.cfg (usually in notepad);

  • Add the line Map clm.map at the end of updmap.cfg (and save the file);

  • In the command prompt, run updmap.

Note: Part 4 of Installing TeX fonts gives similar advice; however, running updmap is replaced by running initexmf --mkmaps. Anyway, the first method worked for me (MiKTeX 2.9, single-user install).

share|improve this answer
    
Now we're getting to regions of using and modifying LaTeX that I've never been to, please help me out here: With command prompt you're just referring to the standard Windows cmd (I'm on Win7)? Do I need to navigate to a specific folder first before carrying out your steps 1 and 3? If I just open cmd and enter your first line, I get an empty document in notepad; where should I save the file? –  doncherry Mar 26 '11 at 10:26
    
@doncherry: Yes, cmd should be the right thing (I'm on a German Win7). No, no specific folder is needed. The document shouldn't be empty, but contain the (comment) line %% T1 font configuration settings. See the MiKTeX manual for help.. If it's empty, add Map clm.map and proceed as described. –  lockstep Mar 26 '11 at 10:32
    
Thanks for clarifying, now it all works! Is it possible though that the file I edited was updmap.cfg and not updmap.sys? –  doncherry Mar 26 '11 at 10:41
    
@doncherry: Of course -- I edited my answer. –  lockstep Mar 26 '11 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.