Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to use small caps roman numbers for chapter numbering using memoir. So far I have tried the following:

\documentclass[oneside]{memoir}
\usepackage[osf]{mathpazo}

\def\thechapter{{\scshape\roman{chapter}}}
\renewcommand{\cftchapterpresnum}{\fontfamily{pplx}\selectfont\bfseries}
\renewcommand{\cftchapterpagefont}{\fontfamily{pplx}\selectfont\bfseries}
\renewcommand{\cftsectionpagefont}{\fontfamily{pplx}\selectfont}

\begin{document}

\tableofcontents

\chapter{The number 4 is more than 2}

\section{The number 4 is}
    If I write chapter \ref{anotherChapter} like this is looks oki.
    But the number in the header is a small i not a \textsc{i} and same
    thing in the table of content and the chapter header\dots
\section{More than 4}
    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Curabitur
    tempus facilisis nunc, sit amet suscipit ligula fermentum ac. Ut
    fringilla, elit eget facilisis venenatis, risus massa viverra sem, a
    placerat massa odio a mauris
\chapter{Another chapter}
    \label{anotherChapter}
\end{document}

However this is not quite fixing it everywhere. It looks good in section listings in the table of content but not in the chapter listings and it looks good in references to the chapter but not in the chapter nor section headings. What more do I need to do?

EDIT: I was trying to make a minimal example but it got a bit too minimal. In my project I am using sans serif for figure captions and after I tried the first version of Lockstep's answer I got this:

\documentclass[oneside]{memoir}
\usepackage[osf]{mathpazo}
\usepackage{helvet}

\renewcommand*{\thechapter}{%
\fontfamily{ppl}\selectfont
\textsc{\roman{chapter}}%
\fontfamily{pplj}\selectfont
}
\renewcommand{\cftchapterpagefont}{\fontfamily{pplj}\selectfont\bfseries}
\renewcommand{\cftsectionpagefont}{\fontfamily{pplj}\selectfont}
\captionnamefont{\sffamily\scshape\small}
\captiontitlefont{\sffamily\small}

\begin{document}

\tableofcontents

\chapter{The number 4 is more than 2}

\section{The number 4 is}
    If I write chapter \ref{anotherChapter} like this is
    looks oki.
    But the number in the header is a small i not a \textsc{i} and same
    thing in the table of content and the chapter header\dots
    \begin{figure}
        \caption{Lorem ipsum}
        \center \LARGE LOREM IPSUM
    \end{figure}
\section{More than 4}
    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Curabitur
    tempus facilisis nunc, sit amet suscipit ligula fermentum ac. Ut
    fringilla, elit eget facilisis venenatis, risus massa viverra sem, a
    placerat massa odio a mauris
\chapter{Another chapter}
    \label{anotherChapter}
\end{document}

Notice that the font for the number in the figure caption now is the wrong one.

share|improve this question

1 Answer 1

The osf option of mathpazo switches to the pplj font family to display oldstyle figures -- but pplj (contrary to ppl) does not feature bold small caps, and so your roman numerals are simply displayed in bold. Because you need a combination of bold small caps and bold oldstyle figures for things like "[Section] i.1", the solution is to switch to ppl and back to pplj within the definition of \thechapter. (You may also want to switch to pplj instead of pplx for ToC page numbers.)

\documentclass[oneside]{memoir}
\usepackage[osf]{mathpazo}
\usepackage{helvet}
\usepackage{etoolbox}

\makeatletter
\renewcommand*{\thechapter}{%
  \ifdefstring{\f@family}{phv}{%
    \textsc{\roman{chapter}}%
  }{%
    \fontfamily{ppl}\selectfont
    \textsc{\roman{chapter}}%
    \fontfamily{pplj}\selectfont
  }%
}
\makeatother
\captionnamefont{\sffamily\scshape\small}
\captiontitlefont{\sffamily\small}

\begin{document}

\tableofcontents

\chapter{The number 4 is more than 2}

\section{The number 4 is}
    If I write chapter \ref{anotherChapter} like this is
    looks oki.
    But the number in the header is a small i not a \textsc{i} and same
    thing in the table of content and the chapter header\dots
    \begin{figure}
        \caption{Lorem ipsum}
        \center \LARGE LOREM IPSUM
    \end{figure}
\section{More than 4}
    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Curabitur
    tempus facilisis nunc, sit amet suscipit ligula fermentum ac. Ut
    fringilla, elit eget facilisis venenatis, risus massa viverra sem, a
    placerat massa odio a mauris
\chapter{Another chapter}
    \label{anotherChapter}
\end{document}

EDIT: Example updated in order to switch only to ppl if the current font family is pplj. The additional code is based on this answer from Mike Renfro; for some reason (expansion?) I had to replace the ifthen package with etoolbox to make it work.

EDIT 2: I don't know why my test for pplj partially fails. Anyhow, a test for phv (Helvetica) succeeds. :-)

share|improve this answer
    
@lockstep: Actually the reason I started to mess around was that I thought the old style numbers for page numbers looked a bit unorganized. I am not sure if people normally stay with old style numbers everywhere or if they usually mix but I thought the old style numbers gave a unorganized impression when used for those page numbers so I thought I should print both variants on paper and give it a good think-over... –  jonalv Mar 27 '11 at 12:40
1  
@jonalv: Also, don't let yourself fool by the size of the small caps -- they are still somewhat larger than oldstyle nums. –  lockstep Mar 27 '11 at 12:42
    
@lockstep: Hm good point. It's still better though, or do you have any suggestions on that topic? I mean they don't look like screaming the way full caps do... –  jonalv Mar 27 '11 at 20:01
    
@lockstep Hm I ran into some further problem. I am using another font for figure captions and now I get the chapter number of the figures written with the wrong font... –  jonalv Mar 27 '11 at 20:26
    
@jonalv: Please give more specific information. –  lockstep Mar 27 '11 at 22:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.