Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using Texmaker 4.0.4 and exported my biblatex.bib from Zotero. My file test.tex:

\documentclass{article}
\usepackage[backend=biber]{biblatex}
\bibliography{Biblatex.bib}
\begin{document}
\cite{campbell2007}
\cite{moffitt86}

\printbibliography 
\end{document}

My biblatex.bib:

@article{moffitt86,
    title = {The econometrics of piecewise-linear budget constraints: a survey and exposition of the maximum likelihood method},
    shorttitle = {The econometrics of piecewise-linear budget constraints},
    pages = {317–328},
    journaltitle = {Journal of Business \& Economic Statistics},
    author = {Moffitt, R.},
    date = {1986},
    file = {Google Scholar Linked Page:files/837/Moffitt - 1986 - The econometrics of piecewise-linear budget constr:}
}


@article{campbell2007,
    title = {"Says who" How the source of price information and affect influence perceived price (un) fairness},
    volume = {44},
    issue = {2},
    pages = {261-271},
    journaltitle = {Journal of Marketing Research},
    author = {Campbell, {M.C.}},
    date = {2007},
    file = {Google Scholar Linked Page:files/912/jmkr.44.2.html:text/html}
}

I am getting an error message with:

! Undefined control sequence.
<to be read again> \edef \blx@tempa {317\x
{FFFD}\x {FFFD}\x {FFFD}328}
l.11 \end
{document}

Any idea about how can I solve this problem?

share|improve this question
1  
This happens when you have "strange characters" in your reference. For example, your pages in reference moffitt86 are 317–328 when it should be 317-328 (different dash). Search for fffd on this site) and you'll see similar problems and how they're fixed. All you have to do is replace the faulty hyphen with -. –  Werner Nov 12 '13 at 20:15
    
This is indeed the case. It should be some bug when exporting the file from Zotero. I will do a find and replace through the biblatex.bib. I'm now having another problem with using a different style but I will do another question. Thanks for the quick response. –  Emanuel Nov 12 '13 at 20:31

1 Answer 1

up vote 2 down vote accepted

Note that this is not a Zotero bug, though. You have set the Zotero export charset to utf-8 and an en-dash is a valid utf-8 character.

You can solve this without search & replace by either using \usepackage[utf8]{inputenc} as e.g. per Highlight changes in a specific entry of a reference list created with biblatex.

Alternatively, you can set the export charset in Zotero to ISO 8859-1, which will escape en-dashes as {\textendash} (the latter option is not available in the biblatex export from Zotero, only in BibTeX)

share|improve this answer
1  
Thanks. The use of \usepackage[utf8]{inputenc} solved the issue smoothly. –  Emanuel Nov 18 '13 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.