Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am a latex user on ubuntu, but not an expert of unix systems. I manage myself for easy things through the terminal. I very frequently refer to forums like stackoverflow to fix the problems that I face. But this time I am really lost... I bought a new pc a week ago and installed Ubuntu 12.04 on it. I have been using texmaker for 3 years now and what I did everytime I had to reinstall it was typing, in a terminal

sudo apt-get install texmaker

It works just fine but I need to add a package called changes. My first try was to install manually the package. I downloaded the package on the ctan webpage and then ran in a terminal

cd /usr/local/share/texmf/tex/latex;
sudo unzip $HOME/changes.zip;
sudo texhash;

When I compiled my file.tex I had some errors and the file.dvi was not build.

My second try was a completely different options. I tried to install texlive and add the package through tlmgr. So, I downloaded install-tl-unx.tar.gz from here and ran

cd /Downloads/ (directory where I downloaded the tar.gz file)
tar -zxvf install-tl-unx.tar.gz;    
sudo ./install-tl -gui perltk;

I checked that texlive 2013 was correctly installed using the instruction of The TEX Live Guide—2013 and everything seems right.

When I try to launch tlmgr I get

tlmgr: command not found

by searching the internet I found that a possible reason to my problem could be that the PATH was not defined so I opened ./profile as root and add the lines

PATH=/usr/local/texlive/2013/bin/x86_64-linux:$PATH; export PATH;
MANPATH=/usr/local/texlive/2013/texmf-dist/doc/man:$MANPATH; export MANPATH;
INFOPATH=/usr/local/texlive/2013/texmf-dist/doc/info:$INFOPATH; export INFOPATH;

Since it didn't seem to make any difference I ran those lines in a terminal

I also ran

updmap-sys

Whatever I try, I keep getting the same error:

tlmgr: command not found

Can anyone help me on that? I really have no idea about what I might have done wrong.

share

migration rejected from stackoverflow.com Feb 1 at 21:46

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as unclear what you're asking by tohecz, Joseph Wright Feb 1 at 21:46

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to TeX.SX! Your post was migrated here from another Stack Exchange site. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Marco Daniel Nov 17 '13 at 9:50