Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm creating a beamer presentation using a custom theme with company logos on the frametitle and footer of the pages. I've got these in EPS format and the resulting document does generate correctly with the images as I expect them.

The problem is that as part of the run, the following 'gs' message appears on the command line:

Error: /undefined in II*
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_
push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1910   1
   3   %oparray_pop   1909   1   3   %oparray_pop   --nostringval--   1893   1   3   %oparray_pop
   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--  
 --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1168/1684(ro)(G)--   --dict:1/20(G)--   --dict:96/200(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 9.02: Unrecoverable error, exit code 1

I've managed to work out what file was causing this by deleting each ????-eps-converted-to.pdf in turn until the message appears, and then I've run ps2eps on the file.

So my question is really two parts:

  1. Most importantly, how could I have diagnosed which file was causing the problem without having to resort to trial and error?
  2. Less so, how is it that the images appear to be OK in the final document?
share|improve this question
    
Can you make the offending eps file available for download? –  Ian Thompson Nov 23 '13 at 17:46
1  
Possibility 1: TeX special characters in the filename. Possibility 2: It seems that the epstopdf package has been invoked. This usually runs a restricted version of epstopdf that invokes gs in safe mode. It is possible that this prevents gs from accessing some special fonts in the EPS file. –  Dan Nov 24 '13 at 5:27
    
@IanThompson: I am probably being overly cautious but as the image forms part of our company branding I would need to check that I can make it available. The .eps was created using Adobe Illustrator. I could grep for things if you think it would be useful? –  Richard Corden Nov 24 '13 at 10:29
    
@Dan: The name of the file is 'Strapline.eps' - but what you say about the fonts could well be the issue. –  Richard Corden Nov 24 '13 at 10:35
    
@RichardCorden --- Adobe Illustrator is the work of Satan, so it's difficult to know what to look for. If I had the file I might recognise something troublesome, but then again I might not. One possibility is garbage at the head or foot of the file. The first and last lines should be %!PS-Adobe-3.0 EPSF-1.2 and %EOF, respectively. If there is anything before/after these, try deleting it. I would probably save the edited file with a different name, as Illustrator may not like the result. –  Ian Thompson Nov 25 '13 at 12:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.