Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am getting an endgroup error. i.e. too many } causing an early closing of the document with the below code. I use sideways tables and floats later on in the document, not sure if this is causing the error.

This is all the preamble info

\NeedsTeXFormat{LaTeX2e}
\documentclass[11pt]{article}


\usepackage{setspace}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{epsfig}
\usepackage{eso-pic}
\usepackage{fancybox}
\usepackage{listings}
\usepackage{algo}
\usepackage{url}
\usepackage{pgfgantt}
\usepackage{natbib} 
\usepackage{sistyle}
\usepackage{epstopdf}
\usepackage{hyperref}
\usepackage{sistyle}
\usepackage{appendix}
\usepackage{pdflscape}
\usepackage{float}
\usepackage{rotating}
\usepackage{graphicx}
\usepackage{rotfloat}
\usepackage{dpfloat}
\usepackage{tcolorbox}
\usepackage{xcolor}


\setlength{\textheight}{9.4in}
\setlength{\textwidth}{7in}
\setlength{\oddsidemargin}{-.25in}
\setlength{\topmargin}{-0.75in} 
\hyphenation{itself}  

Beginning of document and other text then the table that is causing the above error message ! Too many }'s. \color@endbox ->\color@endgroup \egroup

\begin{table}[htbp]
\renewcommand{\arraystretch}{1.25}
\centering
\begin{tabular}{c c c}
    \hline
    \bf{SPI Value} & \bf{Category} & \bf{Pobability \%} \\
    \hline
          2.00 or more & Extremely Wet & 2.3 \\
          1.50 to 1.99 & Severely Wet & 4.4 \\
          1.00 to 1.49 & Moderately Wet & 9.2 \\
          0 to 0.99 & Mildly Wet & 34.1 \\
          0 to -0.99  & Mild Drought & 34.1 \\
          -1.00 to -1.49 & Moderate Drought & 9.2 \\
          -1.50 to -1.99 & Severe Drought & 4.4 \\
          -2 or less & Extreme Drought & 2.3 \\
    \hline

   \end{tabular}%

      \caption[Precipitation anomaly (SPI) classification]{Precipitation anomaly
      classification based on SPI values and corresponding event probabilities}

 \label{tab:SPI}%
\end{table}
share

migration rejected from stackoverflow.com Dec 7 '13 at 22:06

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as unclear what you're asking by Joseph Wright Dec 7 '13 at 22:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
by itself (and taking into account that algo.sty isn't on ctan and thus can't be checked), this doesn't result in an error. so a complete non-working example is needed. it may well be that the error is caused by something earlier in the file, but only shows up when the table is processed. –  barbara beeton Nov 25 '13 at 21:40
    
Using algo.sty from code.google.com/p/latexbfslookahead/source/browse/trunk/… you example code compiles without error. –  Andrew Swann Nov 26 '13 at 8:29
    
Welcome to TeX.SX! Your post was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. A suggestion: Do us a favour and change your username to something more telling than "user1234". –  Martin Schröder Nov 26 '13 at 10:56
    
Without an example that reproduces the problem, this question is likely to be closed during the 'Answer the unanswered' event tomorrow. Please edit your question if you still need help. –  Ian Thompson Dec 6 '13 at 12:43