Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I had to reinstall latex yesterday, and it seems I upgraded from beamer 3.26 to 3.32 So far I used a little piece of code to shade my images, in order to have them behave like for example lists do in transparent mode --- Everything that is yet to come is shown with an opacity of 15% This worked really nicely, however it stopped working and I don't know if this is a bug, or due to some added features. As far as I can make out beamer still doesn't provide this out of the box, so some kind of fiddling is necessary. The question now is, how to get this to work again (short of downgrading beamer) as can be seen from the image (and from my (overly complicated) files) it sometimes works, but not correctly.

  • The image is uncovered in frame 2, even though it should be uncovered in frame 3 (I only attached frame 1)
  • Further images are not shaded at all

This worked fine before (and was most useful together with \llap{} to superimpose tranparent pictures on top of other stuff

result in 3.32

\documentclass{beamer}
\usepackage{ifthen}
\usepackage{tikz}

\makeatletter
\newcommand{\includecoveredgraphics}[2][]{
    \ifthenelse{\the\beamer@coveringdepth=1}{
        \tikz
            \node[inner sep=0pt,outer sep=0pt,opacity=0.15]
                {\includegraphics[#1]{#2}};
    }{
        \tikz
            \node[inner sep=0pt,outer sep=0pt]
                {\includegraphics[#1]{#2}};%
    }
}

\makeatother

\begin{document}
\begin{frame}
\setbeamercovered{transparent}
\begin{itemize}[<+->]
\item First point.
\item Second point.
\item Third point.\includecoveredgraphics[width=2cm]{test1}
\item Fourth Point \includecoveredgraphics[width=5cm]{test2}
\end{itemize}
\end{frame}
\end{document} 
share|improve this question

closed as off-topic by Joseph Wright Feb 1 at 21:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Joseph Wright
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
this is the commit that broke your code: bitbucket.org/rivanvx/beamer/commits/… If you comment out those lines in beamerbaseoverlay.sty your MWE will work fine again. This should be reported to the beamer mantainer, I assume. –  dcmst Nov 27 '13 at 9:55
1  
Yes, commenting those lines out indeed restores my files. May I ask how you knew that it was that particular part of code (as in: could I have found that out myself?) –  Bernhard Nov 27 '13 at 10:18
    
I tested your code with version 3.31 and it worked fine, since there were only three commits between 3.31 and 3.32 and the other two were about totally unrelated stuff, I tried commenting out that commit and it worked. However please note that this is not the proper solution, as I said this should be reported (or maybe someone with a deeper knowledge will come up with a proper solution). –  dcmst Nov 27 '13 at 10:25
    
I am aware of that, and wanted to append my comment, but I was too slow. Joseph Wright is quite active here, if he doesn't see this in a reasonable amount of time I'll file a bug-report (for a hack that stopped working, which to me seems a bit over the top) –  Bernhard Nov 27 '13 at 10:35
2  
I think I see the issue: \tikz uses \endtikzpicture internally without the grouping that really should be present (as \endtikzpicture is what is supposed to be used for \end{picture}). Solution at the beamer end is I think doable, although arguably this is a not-so-great approach by TikZ. –  Joseph Wright Nov 27 '13 at 10:37
show 8 more comments