Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This is going to be a simple addendum to my previous question (detailed enough I think, with image proofs) on how to set properly file associations on my machine; OS: Windows 7 64 bit Professional, LaTeX: MikTeX v2.94 x64 Updated October 2013.

As a result, @karlkoeller gave an amazing solution, a re-implementation of all the connections between file extensions and programs inside a file additions.reg; this worked well to obtain a result with *.tex, *.cls, *.bib et similia.

The main request would be on the last extension available, *.dvi, i.e. having installed correctly YAP, I only need the specified association inside Windows Registry by another additionsdvi.reg, since the result at the moment is the same as my first question:

enter image description here

As it can be seen, on the File Type it appears as File DVI, the same as File CLS. This is windows itself that does not have a clue on which program has to be assigned, as it did the last time with the class extension.

My experience is not enough to mess with this important stuff, as I learned it on my skin by "fighting" 7 hours straight as my PC slowly turning into complete chaos (I solved by a rough reboot, which I do not want it to repeat again).

share|improve this question
    
Double clicking on the icon does anything? –  egreg Nov 28 '13 at 17:36
    
@egreg The icon it's here only because I had to manually add YAP to a *.dvi file. If I hadn't done that, there would've been a blank icon with no program associated. Question edited to represent my initial condition. –  Andrea L. Nov 28 '13 at 17:38
    
What happened with the context menu and the option Open with...? When I used to use Win this options was there and you could associate a program to each file type. –  Sigur Nov 28 '13 at 21:38
    
@Sigur Surely I could have done this in the first place, but see, the difference between this method and the Registry implementation lies inside the user specified file association: if the user decides to assign by itself an extension opener program, then the file opens without problems; but the registry has different information (different icon set, minor changed options, backwards compatibility,...) than applying a direct *.reg file. It's like telling a machine to do automatic work instead a step-by-step human acting on the process. –  Andrea L. Nov 28 '13 at 21:59
1  
@Sigur To be strict: Yes, I could have done that, but the minor changed options (icons, other evil stuff that may be affecting me on the future...). But instead I wanted that Windows would not ask me the association file program in the first place, since it's not already implemented inside the registry. –  Andrea L. Nov 28 '13 at 22:10
add comment

1 Answer 1

up vote 4 down vote accepted

Following what you've done in the previous thread, now the contents of the file additions.reg has to be:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.dvi]
@="MiKTeX.dvi.2.9"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9]
@="DVI File"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\DefaultIcon]
@="C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\yap.exe,1"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell]

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\open]

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\open\command]
@="C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\yap.exe /dde"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\open\ddeexec]
@="[open(\"%1\")]"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\print]

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\print\command]
@="C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\yap.exe /ddenoshow"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\print\ddeexec]
@="[print(\"%1\")]"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\printto]

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\printto\command]
@="C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\yap.exe /ddenoshow"

[HKEY_CLASSES_ROOT\MiKTeX.dvi.2.9\shell\printto\ddeexec]
@="[printto(\"%1\",\"%2\",\"%3\",\"%4\")]"
share|improve this answer
    
You definitely deserve a coffee... =) –  Andrea L. Nov 28 '13 at 17:55
    
@AndreaL. Troppo gentile... –  karlkoeller Nov 28 '13 at 17:56
    
In verità è gentile colui che dedica tempo a chiarimenti (almeno a me) essenziali. –  Andrea L. Nov 28 '13 at 17:59
    
@AndreaL. Coffee! not a beer? ;-) –  Harish Kumar Nov 28 '13 at 22:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.