Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use the caption package.
Somehow I got a period between the type (Figure) and the separator (:) When I wrote

listformat=empty,

for the Table of Figures, I just got the period and then the caption text.

I have no idea, but the period just appeared when I tried to skip the chapter numbering

(\counterwithout{figure}{chapter})

One way or the other, I always have the period which looks like:

Figure 1.: Description

EDIT:
I tried it, but I couldn't get it to run. That's everything I have regarding the captions. But somehow I think somewhere is some more. I just can't remember.

\documentclass[
12pt, % Schriftgröße
%DIV10,  % Teilung der Seite in 10 Teile (Layout bessere Lesbarkeit)
ngerman, % für Umlaute, Silbentrennung etc.
a4paper, % Papierformat
oneside, % einseitiges Dokument (Standard)
titlepage, % es wird eine Titelseite verwendet
parskip=half, % Abstand zwischen Absätzen (halbe Zeile)
headings=normal, % Größe der Überschriften verkleinern
listof=totoc, % Verzeichnisse im Inhaltsverzeichnis aufführen
bibliography=totoc, % Literaturverzeichnis im Inhaltsverzeichnis aufführen
%index=totoc, % Index im Inhaltsverzeichnis aufführen
listof=flat,
captions=tableheading, % Beschriftung von Tabellen unterhalb ausgeben
final % Status des Dokuments (final/draft)
]{scrreprt}

\usepackage{chngcntr}
\usepackage[
labelfont=bf,
%   labelsep=none,
listformat=simple,  % simple ist defaultwert.
]{caption}

\counterwithout{figure}{chapter}

\usepackage[demo]{graphicx}




\begin{document}
\listoffigures
\begin{figure}[htb]
\begin{center}
\leavevmode
\includegraphics[width=0.8\textwidth]{foo.jpg}
\end{center}
\caption{Beispiel einer Matrixkombination}
\label{fig:Matrixknoten}
\end{figure}


\end{document}
share|improve this question
2  
A full but minimal example would be very helpful. –  Thorsten Donig Apr 3 '11 at 17:49
    
I am aware of that, but since I cant reproduce the mistake, I cannot upload anything. I cannot strip my document far enough to load it up. :-( –  MiKa Apr 3 '11 at 17:52
    
But with the information you gave it is nearly impossible to give specific help. There is something in your code that seems cause this misbehaviour. But without seeing that code the problem is incomprehensible (at least for me). –  Thorsten Donig Apr 3 '11 at 17:56
3  
@MiKa I fixed your code so that it compiles, but your example doesn't actually show the problem you're having. Have you redefined \thefigure anywhere in your actual document? –  Alan Munn Apr 3 '11 at 18:31
1  
@MiKa what about \captionformat or \figureformat? –  Alan Munn Apr 3 '11 at 19:06
show 5 more comments

1 Answer 1

up vote 3 down vote accepted

In document class scrreprt if you use the Appendix, you automatically get a period after the number.
To solve the problem you need to load the class with the option:

numbers=noendperiod

Thanks for your help!

share|improve this answer
    
since you have found the solution to your own problem, you should accept your own answer. (You may have to wait a day to do this, but please come back and accept it when you can.) –  Alan Munn Apr 3 '11 at 20:33
    
@Alan: I know I have to, but I can't, I have to wait 2 days. :-S That should be changed... –  MiKa Apr 3 '11 at 20:41
1  
It is sometimes annoying, but I don't think it's going to change. I was just reminding you in case you weren't aware that you can actually accept your own answer (which you are.) –  Alan Munn Apr 3 '11 at 21:28
    
@Alan, that's very thoughtful of you, thank's. –  MiKa Apr 4 '11 at 7:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.