Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using TexStudio and am very happy with it. Now I have discovered the subfiles package to be able to compile only the part of my document I am working on. But TexStudio detects that the document is inputted into my main document and compiles the main document instead.

My current workaround is to set the subfile as current master document, but that is quite clumsy. I have not found any option to turn off the automatic master mode in TexStudio, did I overlook something?

share|improve this question
    
wild guess since I'm not familiar with TeXStudio: couldn't you just comment out from the main file the \subfile commands you don't want to include in compilation and then compile the main file as usual? –  dcmst Dec 6 '13 at 13:35
    
Well, that would be a workaround as well, because then I have to take care that I reinclude it into the main file. What I want is just to compile the currently active tab and remove TexStudios intelligence. –  Mazza Dec 6 '13 at 13:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.